All Apps and Add-ons

Errors with Rapid7 InsightVM TA

adalbor
Builder

Hey All,

Hoping someone can help with an issue with the Rapid 7 Insight VM TA.

We recently upgraded the app from 1.0.5 to 1.1.0. After upgrading the app stopped working and started throwing an error.

The GUI for the app would no longer completely load after the upgrade, config\inputs page would halfway load and just spin.

I removed the new version and re-installed the older version 1.0.5 but still the same issues. Is anyone else having issue with it that might be able to assist?

Splunk Version: 8.1.1

App is installed on a HF

We get the attached error in the newer version and the older version now.

Seeing alot of these python related errors also:

06-15-2021 10:04:01.511 -0500 ERROR ScriptRunner - stderr from '/opt/splunk/bin/python3.7 /opt/splunk/bin/runScript.py setup': ImportError: cannot import name 'validator' from 'splunktaucclib.rest_handler.endpoint' (/opt/splunk/etc/apps/TA-rapid7-insightvm/bin/ta_rapid7_insightvm/aob_py3/splunktaucclib/rest_handler/endpoint/__init__.py)
Labels (1)
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...