All Apps and Add-ons

Does the Kafka Messaging Modular Input support Kafka 0.9 or above?

New Member

I need this version of KAFKA for the security features added - specifically client authorization/authentication to control access to topics

0 Karma

Ultra Champion

Currently it supports 0.8.1.1 , https://splunkbase.splunk.com/app/1817/#/documentation

Code is on github should you wish to fork it and cut a 0.9 version 🙂

0 Karma

New Member

OK thanks Damien, the consumer API has completely changed from 0.8.1.1 to 0.9 so might not be something our team has the time/appetite for but we are pretty stuck without it - we dont have an option on what KAFKA version we are consuming its 0.9 or later and we have to use client certs so we are cornered..

0 Karma

New Member

Sorry I should have mentioned the client based authorisation in KAFKA we need to use is certificate based so its not only support for Kafka 0.9 but also support in the modular input module to configure a certificate to send when connecting to Kafka 0.9 ;O)

0 Karma