All Apps and Add-ons

DB Connect - connection has special charactor in SQL server name

Barty
Explorer

Good afternoon guys,

Hoping you will be able to assist with this one - we have configured a number of SQL DB connections without a hiccup, but sadly there are a few that we cannot establish due to the fact that they have '\' in the server name. Example being:-

testserver01\testserver

Could someone advise how we include the final part of the connection name as presumably the '\' is causing splunk to escape it or not accept that name. The error produced is:-

Unknown server host name
'testserver01\testserver.domain.net'

0 Karma

Barty
Explorer

I don't suppose anyone else has ecountered this then or managed to find a work around??

0 Karma

Azeemering
Builder

What does the host string look like in the db_connections.conf file?
Can you try escaping it with another backslash maybe? (\)

For example:
[oracle_example]
connection_type = oracle
database = orcl
disabled = 0
host = oracle.host.com
identity = oracle_identity
jdbcUseSSL = true
port = 2484
readonly = false
customizedJdbcUrl = jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcps)(HOST=oracle.host.com)(PORT=2484))(CONNECT_DATA=(SERVICE_NAME=orcl)))
connection_properties = {"oracle.net.authentication_services": "(TCPS)", "oracle.net.ssl_cipher_suites": "(SSL_DH_anon_WITH_3DES_EDE_CBC_SHA, TLS_RSA_WITH_AES_128_CBC_SHA)", "javax.net.ssl.trustStore": "/opt/splunk/cwallet/cwallet.sso", "javax.net.ssl.trustStoreType": "SSO", "javax.net.ssl.keyStore": "/opt/splunk/cwallet/cwallet.sso", "javax.net.ssl.keyStoreType": "SSO"}

0 Karma

Barty
Explorer

Good thinking, I've had a look and having amended the JDBC URL so that in saves to the db_connections.conf file (it wasn't a customer URL before) We have the following:-

[#######.group.net]
connection_type = mssql_jtds_win_auth
database = lv_monitoring
disabled = 0
host = #########.group.net
identity = SQL_Audit
jdbcUseSSL = false
localTimezoneConversionEnabled = false
port = ####
readonly = false
customizedJdbcUrl = jdbc:jtds:sqlserver://mytest\test:1433/lv_monitoring;useCursors=true;domain=<domain_name>;useNTLMv2=true

I have hashed out some info. I've played around with this and tried inputting it with the path contained within [ ] but to no luck, nor inputting '\' to escape the single item. Really at a loss on this

0 Karma

Barty
Explorer

Morning guys, I don't suppose anyone is able to shed some light on this? Sadly the DBA I am working with has gone on holiday for a fortnight - so I'm little in the dark haha!

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...