All Apps and Add-ons
Highlighted

DB Connect V2 Execution Frequency

Communicator

Splunk DB Connect V2 Execution frequency

In the splunk DB connect V2, there is an option during DB Input called Execution
Frequency. I always had 120 seconds as the Execution frequency. I didnt have
any issues with it. recently it has been ingesting the same data over and over
again every 2 minutes. I had to change it to a very large number (i.e. 31104000).
Now it stopped ingesting the same data again and again.

As far as I can remember, this was working fine with 120 seconds before, has
anyone had the same issue with the Splunk DB Connect V2 ? I am using it to connect to postgresql.

0 Karma
Highlighted

Re: DB Connect V2 Execution Frequency

Communicator

OK seems this also doesnt work, currently its re-indexing the same data, in my search query I see duplicate events, the longer I wait the more duplicate data is ingested

0 Karma
Highlighted

Re: DB Connect V2 Execution Frequency

Esteemed Legend

If you only need to do it once, then set it up, let it run, and then disable it. Otherwise, it will run every time execution frequency time passes.

View solution in original post

Highlighted

Re: DB Connect V2 Execution Frequency

Communicator

I disabled the index, now I cannot search the data in query

How can I disable the index and still search the data.

0 Karma
Highlighted

Re: DB Connect V2 Execution Frequency

Esteemed Legend

Don't disable the index, disable the input.

0 Karma
Highlighted

Re: DB Connect V2 Execution Frequency

Communicator

Thanks I did just that, disabled DB Input in Splunk DB Connect V2. So far I do not see anymore new data ingestions, I will wait a bit hope this fixes it. Thanks!

0 Karma