All Apps and Add-ons

DB Connect MySQL can't parse timestamp



I am using DB connect 3.1.1 to get data from MySQL. I have 15 working inputs with rising id column and timestamp (DATETIME) to index data. Server and table structure is same for all inputs.
But for 4 next inputs, I get this message in db_connect_server.log :

2018-01-23 00:39:47.459 +0100  [QuartzScheduler_Worker-28] ERROR org.easybatch.core.job.BatchJob - Unable to open record reader
java.time.format.DateTimeParseException: Text '2017-12-04 10:58:57.0' could not be parsed, unparsed text found at index 19
    at java.time.format.DateTimeFormatter.parseResolved0(Unknown Source)
    at java.time.format.DateTimeFormatter.parse(Unknown Source)
    at com.splunk.dbx.server.dbinput.recordreader.columnprocessor.RowWithTimeProcessor.extractTimestampFromString(
    at com.splunk.dbx.server.dbinput.recordreader.columnprocessor.RowWithTimeProcessor.apply(
    at com.splunk.dbx.server.dbinput.recordreader.columnprocessor.RowWithTimeProcessor.apply(
    at com.splunk.dbx.server.dbinput.recordreader.iterator.EventPayloadRecordIterator.hasNext(
    at org.easybatch.core.job.BatchJob.openReader(
    at org.easybatch.extensions.quartz.Job.execute(
    at org.quartz.simpl.SimpleThreadPool$
2018-01-23 00:39:47.459 +0100  [QuartzScheduler_Worker-28] INFO  org.easybatch.core.job.BatchJob - Job 'psa-wfk-lc_04307600_xx' finished with status: FAILED

The timestamp column is also DATETIME and everything is fine in GUI wizard to select column for timestamp. Please do you have any idea what can be wrong?

0 Karma

Path Finder

Did you resolve this ? I have the exact same problem at the moment. My same query worked in version 2.4 we upgraded to 3.1.1 and now same query same data input doesn't work due to time format with the same error you had.

0 Karma


"Index 19" is, if I count correctly, the "." separating seconds from the "0" for tenths of a second. That brings up a couple of possibilities. First, double check against a known-good one (one that works) exactly what type of data the data and time is coming from. Then check exactly what the query is you are running. I'll bet either the column types are different, or there's a cast/convert (or whatever MySQL uses for that) in the ones that work. For that matter, what's the timestamp time specifier you put into the GUI? (Do you still have to do that?)

0 Karma


Could you try converting timestamp field in sql query?

0 Karma
Get Updates on the Splunk Community!

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...

Introducing the Splunk Community Dashboard Challenge!

Welcome to Splunk Community Dashboard Challenge! This is your chance to showcase your skills in creating ...