All Apps and Add-ons

DB Connect 2 - Connections not loading after Splunk / DB Connect 2 upgrade

najeebshaik
Engager

Hi,

I had Splunk V6.3.1 with DB Connect 2 V2.0.6 working fine.
Because of the incorrect date reporting I upgraded DB Connect 2 to V2.1.2, which fixed the issue.
Then I decided to upgrade Splunk to V6.3.2 which broke DB Connect. In the Explorer window Connections were not loading but everything worked fine.
In the splunkd.log the following error are getting logged everytime Connections page is accessed.

"02-11-2016 14:45:27.549 -0600 ERROR AdminManagerExternal - Stack trace from python handler:\nTraceback (most recent call last):\n File "/dev/splunk-test/splunk/lib/python2.7/site-packages/splunk/admin.py", line 70, in init\n hand.execute(info)\n File "/dev/splunk-test/splunk/lib/python2.7/site-packages/splunk/admin.py", line 529, in execute\n if self.requestedAction == ACTION_LIST: self.handleList(confInfo)\n File "/dev/splunk-test/splunk/etc/apps/splunk_app_db_connect/bin/rh_connection_types.py", line 61, in handleList\n self.addDriverInfo(obj, info)\n File "/dev/splunk-test/splunk/etc/apps/splunk_app_db_connect/bin/rh_connection_types.py", line 32, in addDriverInfo\n driverClass = ent['jdbcDriverClass']\n File "/dev/splunk-test/splunk/lib/python2.7/site-packages/splunk/entity.py", line 535, in getitem\n return self.properties[key]\nKeyError: 'jdbcDriverClass'\n
02-11-2016 14:45:27.549 -0600 ERROR AdminManagerExternal - Unexpected error "" from python handler: "'jdbcDriverClass'". See splunkd.log for more details."

Then I upgraded Splunk to 6.3.3 to see if it resolves the issue but no go. I upgraded DB Connect 2 to V 2.1.3 still the same issue is getting reported in the logs and Connections page is not getting loaded.

Has any body seen this issue so far..

Thanks
Najeeb

0 Karma

badrinath_dash
Explorer

We had a similar problem in our SPLUNK instance where the connection page was not loading, later we identified that the default RPC Server port ( 9998 ) was used by some other application.

We changed the default RPC server port and it is loading fine.

0 Karma

jcoates_splunk
Splunk Employee
Splunk Employee

yeah, that's a corrupted installation. Don't know why, but if it's repeatable we'd like a bug.

0 Karma

najeebshaik
Engager

Removed DB connect 2 app and reinstalled it, first 2.0.6, then 2.1.2 and and last 2.1.3. Also upgraded Splunk to V6.3.3. Everything seems to work now and it looked like some files might have got corrupt during the upgrades.

Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.