All Apps and Add-ons

Azure TA 2.0 not working and error codes

Explorer

Installed 2.0 and cannot get inputs to load on the webui. Have the following error. Any help is GREATLY appreciated.

Unable to initialize modular input "azure_event_hub" defined inside the app "TA-MS-AAD": Introspecting scheme=azure_event_hub: script running failed (exited with code 1).

Path Finder

Found a workaround. This should not be permanent but just until a fix is found. In my previous post I identified that the problem is with some DLL. Decided to omit the troubled line from the code in the first .py script.
GoTo-->C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin(or whatever your Splunk Directory is) --> edit azure_event_hub.py --> go to line 14 --> and place a pound(#) sign in front of the line it should look like this (#import input_module_azure_event_hub as input_module) --> then got to line 117 and do the same (#exitcode = ModInputazure_event_hub().run(sys.argv)) --> then go to line 118 and remove the word exitcode from with in parenthesis so it would look like this (sys.exit()) --> Be sure to restart splunk for Input tab to start working.

Thanks,
Arthur

Loves-to-Learn

Hi  @agadayev, I have the same issue on using app version 2.1.1 on Splunk 7.3.6 (I can't upgrade the application to 3.0.1). I have applied the fix you suggested, but still have this issue. 

Any idea about it?  My Splunk runs on Windows 2016.

0 Karma

Path Finder

Was there ever a fix for this issue?

Further investigation: I ran in admin cmd window
cd C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin
python azure_event_hub.py
Got the following output:
"Traceback (most recent call last):
File "azure_event_hub.py", line 14, in
import input_module_azure_event_hub as input_module
File "C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin\input_module_azure_event_
hub.py", line 10, in
from azure.eventhub import EventHubClient, EventData, EventPosition
File "C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin\azure\eventhub_init.p
y", line 8, in
from azure.eventhub.common import EventData, EventDataBatch, EventPosition
File "C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin\azure\eventhub\common.py"
, line 13, in
from azure.eventhub.error import EventDataError
File "C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin\azure\eventhub\error.py",
line 9, in
from uamqp import constants, errors, compat
File "C:\Program Files\Splunk\etc\apps\TA-MS-AAD\bin\uamqp__init
_.py", line
17, in
from uamqp.windows import c_uamqp # pylint: disable=import-self
ImportError: DLL load failed: The specified module could not be found."

The version is 2.0.2

If anyone knows what DLL is missing please let us know.
Thank you,
Arthur

0 Karma

New Member

2.0.2 is still displaying the same issue:
Unable to initialize modular input "azure_event_hub" defined in the app "TA-MS-AAD": Introspecting scheme=azure_event_hub: script running failed (exited with code 1)..

0 Karma

Contributor

2.0.1 gives me the same error, tried using 1.2.4 but get a 401 error. Noticed it's calling https://graph.microsoft.com/beta. Perhaps 1.2.4 is deprecated?

0 Karma

New Member

same issue. looks like this version is buggy

0 Karma

Engager

I am having the same issue with 2.1

0 Karma