All Apps and Add-ons

ActiveMQ / JMS Modular Input: message from "python /opt/splunk/etc/apps/jms_ta/bin/jms.py" Stanza jms://queue/:camel.q.timer : Error connecting : javax.naming.NameNotFoundException: camel.q.timer

New Member

We are trying to connect ActiveMQ to Splunk (using JMS Modular Input) but keep receiving the following error:

ERROR ExecProcessor - message from
"python
/opt/splunk/etc/apps/jms_ta/bin/jms.py"
Stanza jms://queue/:camel.q.timer :
Error connecting :
javax.naming.NameNotFoundException:
camel.q.timer

Does anyone can help or explain if we need to add more files than only the activemq.jar? and need specific configurations?

These are the settings:

Our jdni name (in karaf) JNDI Name

Class Name osgi:service/jms/test

org.apache.activemq.ActiveMQConnectionFactory

Settings in Splunk: Data inputs -> JMS Messaging

Output Settings

Data Output: STDOUT

Initialisation Mode: jdni

Initialise connection objects via JNDI
or Local instantiation.

JNDI Initialisation Mode Settings:
JMS Connection Factory JNDI Name:
ConnectionFactory

JNDI Initial Context Factory Name:
org.apache.activemq.jndi.ActiveMQInitialContextFactory
//we put the activemq jar in
/opt/splunk/etc/apps/jms_ta/bin/lib/activemq-all-5.15.9.jar

JNDI Provider URL:
tcp://localhost:61616

JNDI Username

JNDI Password •••••••••••••••
Password for authenticated JNDI
connections

0 Karma