All Apps and Add-ons

AWS Kinesis Modular Input: How to resolve error "It has been determined via the REST API that all inputs have been disabled"?

Explorer

I've installed Amazon Kinesis Modular Input Version: 1.0.3 on Splunk 6.5.0 and I get an error in splunkd.log and there is no Kinesis input in /en-US/manager/launcher/datainputstats

Anyone got any ideas what is wrong here? Could it be because I'm installing this on a Splunk management server in a cluster?

03-03-2017 12:47:13.484 +1300 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/kinesis_ta/bin/kinesis.py" It has been determined via the REST API that all inputs have been disabled

# /opt/splunk/bin/splunk --version
Splunk 6.5.0 (build 59c8927def0f)

# /opt/splunk/jre1.7.0_01/bin/java -version
java version "1.7.0_01"
Java(TM) SE Runtime Environment (build 1.7.0_01-b08)
Java HotSpot(TM) 64-Bit Server VM (build 21.1-b02, mixed mode)

# /usr/bin/python -V
Python 2.6.6

I can successfully run this command and it produces valid XML output

./splunk cmd python ../etc/apps/kinesis_ta/bin/kinesis.py --scheme
0 Karma

Contributor

Hi , I have the same problem, but with different app(JMS modular input). I can see the app in Settings --> Add Data --> Monitor but not under data inputs. Could you please tell me how you have solved this problem.

0 Karma

Ultra Champion

Browse to Data Inputs -> Kinesis

Is the input stanza enabled ?

You only get that message when then input is disabled or you restart Splunk.

Explorer

Hi Damien, thanks for your quick reply.

If I go to Settings --> Data Inputs (https://splunk:8000/en-GB/manager/launcher/datainputstats) then there is NO Kinesis link. It only has Files & directories, TCP, UDP, Scripts and Database Inputs.

However, I've found that I can go to where the Kinesis input should be at https://splunk:8000/en-US/manager/launcher/data/inputs/kinesis then I DO see the Kinesis page.

Also, if I go Settings --> Add Data --> Monitor then I get an Amazon Kinesis option there.

I suppose that's a work around but I'm a bit puzzled why the Kinesis TA doesn't appear in the list in Settings --> Data Inputs...

0 Karma

Explorer

Another question, is there a way to configure the Kinesis TA to use a proxy server?

0 Karma

Contributor

Hi , I have the same problem, but with different app. I can see the app in Settings --> Add Data --> Monitor but not under data inputs. Could you please tell me how you have solved this problem.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!