Alerting

Regroup Alerts

honolulu95
New Member

Hello, please i need to know how i can create an alert that groups together several other alerts.
Or Maybe to create an alert regrouping 2 or 3 event logs in splunk.
Thank you.

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @honolulu95,
could you better describe your need?

In Splunk every alert, report or dashboard panel is a search; so you cannot group more alerts, but maybe (I don't know your requirement) it's possible to create a search that contains the searches of more alerts.
e.g. if you need to check if there are logs from two different sources (eventually stored in different indexes), you don't need to create two alerts, you can create an alert that checks the two sources.
e.g. events from Windows and Linux OSs, stored in os and wineventlog index:

index=os OR index=wineventlog
| stats dc(index) AS count 
| where count<2

Ciao.
Giuseppe

0 Karma

to4kawa
Ultra Champion

There's no such feature.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...

Event Series: Mastering AI Tokenomics and Splunk Agent Observability

Beyond the Black Box: Correlating AI Performance and Tokenomics with Splunk Agent Observability   As ...

span_metrics: The OpenTelemetry-Idiomatic Way to See Inside Your Services

You open a trace in Splunk Observability Cloud and everything looks fine. One root span, order-pipeline, with ...