Alerting

How to remove hyphens at the end of alerts

sochsenbein
Communicator

We are seeing a weird bug with our alerts Email action. The emails are just fine, however, when we use our paging system (page.), it adds a bunch of hyphens at the end of the page. Any ideas why? I have tried shortening the message, toggling between HTML & Plain Text and just Plain Text.

What we should see:
The Output has fallen below the Limit:

Output: 23344
Limit: 25000

What we actually see:

Output: 23344
Limit: 25000

--------------------
------
0 Karma
1 Solution

sochsenbein
Communicator

This was caused by our paging server stripping the HTML from the message.

View solution in original post

0 Karma

sochsenbein
Communicator

This was caused by our paging server stripping the HTML from the message.

View solution in original post

0 Karma

niketnilay
Legend

@sochsenbein have you tried to switch between Plain Text type and Html & Plain Text Type for email? https://docs.splunk.com/Documentation/Splunk/latest/Alert/Emailnotification#Define_an_email_notifica...

(Optional) Change the email Type to
Plain Text. Type is set to HTML &
Plain Text by default.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

sochsenbein
Communicator

@niketnilay I have

0 Karma

sochsenbein
Communicator

I will not show the first line in the body of the message, and appears to eliminate the hyphens when I include some sort of attachment, such as a link to the alert, results, etc.

0 Karma

sathwikr076
Communicator

As @niketnilay mentioned if you have "plain text type", you will see the hyphens you are talking about but if you switch to Html & Plain Text Type you won't see anything even if you do not add any attachment options. I just tried it myself.

0 Karma

sochsenbein
Communicator

@sathwikr076 as mentioned in the original post, I tried toggling between the two and it shows the hyphens regardless. That works for emails, but when routing the email to our paging system, the text that comes through has the hyphens added.

0 Karma

sathwikr076
Communicator

I got the below message with Html & Plain Text Type

The alert condition for 'test' was triggered.

If you believe you've received this email in error, please send a message to
splunk > the engine for machine data

I got this with plain text type

The alert condition for 'test' was triggered.

If you believe you've received this email in error, please send a message to
splunk > the engine for machine data

0 Karma

sochsenbein
Communicator

@sathwikr076 right, I get the same thing when sent to email, but the text that comes through still has the hyphens. I am not sure what we use to route emails through to pages, I will need to find that out.

0 Karma

sathwikr076
Communicator

Hi,
I had similar issue with the alert action. i had PDF file in the alert which i scheduled to send an email. The PDF file should only have raw logs but we got visalization of our query at the first page of the PDF file. i had to change some settings in the "adavnced edit" on that alert.
I changed display.visualizations.show = 0.

Thanks.

0 Karma

sochsenbein
Communicator

@sathwikr076 where are you seeing the Advanced Edit? Also, for my alert, I do not have anything attached. Even just having "Test message" in the body of the page results in only getting hyphens in the page. It appears that the first line is replaced with hyphens.

0 Karma

sathwikr076
Communicator

settings->Searches, Reports, and Alerts->edit. I am not getting where you are having an issue. do you have any reference?

0 Karma

sochsenbein
Communicator

@sathwikr076 The problem is the page I get to my phone. Using the email action to route to a page rather than email. When it gets to the phone, there are a bunch of hyphens.

0 Karma

sochsenbein
Communicator

I found the advanced edit and disabled the display.visualizations.show, but still getting the hyphens.

0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!