Splunk Search

help fixing cli search with sourcetype specified

alfredoh14
Engager

when i type in the command line (cmd not powershell):
splunk search "*" -maxout 0 | find /c /v ""

I get the return of about 195k records.

however when i filter by one of the sourcetype, from one of the splunk free tutorials, by typeing:
splunk search "*" 'sourcetype=e' -maxout 0 | find /c /v ""

I still get the same result of 195k records.

the "| find /c /v "" " should return only the line count.
so if i filter by the sourcetype it should return around 165k records which are the number of records associated with that source type currently in my splunk db.

can someone help me correct my syntax, i tried google searches but none were able to give me an example, which I think is due to the fact I do not know how the syntax should work in the first place.
I am using the windows cmd, and I plan to use the windows cmd, not the website interface, thanks for understanding.

Labels (1)
0 Karma

tscroggins
Motivator

@alfredoh14 

In your examples, "*" is your search string. To expand it, add search terms to that string:

splunk search "* sourcetype=e" -maxout 0 | find /c /v ""

To dispense with find and have Splunk report the event count:

splunk search "* sourcetype=e | stats count"

If you know the index you're searching, you can use tstats for much faster results:

splunk search "| tstats count where index=main sourcetype=e"

0 Karma
Get Updates on the Splunk Community!

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...

Five Subtly Different Ways of Adding Manual Instrumentation in Java

You can find the code of this example on GitHub here. Please feel free to star the repository to keep in ...

New Splunk APM Enhancements Help Troubleshoot Your MySQL and NoSQL Databases Faster

Splunk Observability has two new enhancements to make it quicker and easier to troubleshoot slow or frequently ...