Splunk Search

How to pull RDP Connections in my environment?

Cyberguru
Engager

Query doesnt bring up anything.

Try to pull RDP connections in my environment: 

 

 

event_simpleName=UserLogon LogonType_decimal=10

| stats values(UserName) dc(UserName) AS "User Count" count(UserName) AS "Logon Count" by aid, ComputerName

| sort - "Logon Count"

 

Labels (3)
Tags (1)
0 Karma
1 Solution

yuanliu
SplunkTrust
SplunkTrust

First, illustrate your raw data.  Are "aid" and "ComputerName" available at search time, AND are they present in (at least some of) the same events?  For example, what does this give you?

event_simpleName=UserLogon LogonType_decimal=10
| table aid, ComputerName

Also, the search appears to be about user name.  How does this relate to "pulling RDP connections" in the title?

View solution in original post

0 Karma

Cyberguru
Engager

Thanks for the answer

0 Karma

yuanliu
SplunkTrust
SplunkTrust

First, illustrate your raw data.  Are "aid" and "ComputerName" available at search time, AND are they present in (at least some of) the same events?  For example, what does this give you?

event_simpleName=UserLogon LogonType_decimal=10
| table aid, ComputerName

Also, the search appears to be about user name.  How does this relate to "pulling RDP connections" in the title?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Continue Your Federation Journey: Join Session 3 of the Bootcamp Series

To help practitioners build a stronger foundation, we launched the Data Management & Federation ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Casting Call: Compete in Cyber Games

Lights, Camera, SecOps: Apply to Compete in Cyber Games     Think you have what it takes to beat the clock? ...