Splunk Enterprise

How to Deactivate SPL safeguards on Splunk Enterprise

jotne
Communicator

I have upgraded my Splunk Enterprise to 9.0 and we now get warning like this:

Some visualizations have not loaded since we detected usage of risky commands in the query.

This is OK,  and I now why and this dashboard is for admin use only.   So I like to Deactivate the warning for this dashboard only.  That way I will get warning if there are other dashboard with dangerous commands.  But if I read the documentation, it seems that I can only disable all warning or warning for some commands.  I would like to disable warning pr dashboard.  Anyone has a workaround?

https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/SPLsafeguards?ref=hk

Labels (1)
0 Karma

Azeemering
Builder

Hi,

I think it is possible to disable / enable these warning per app level.

So if you add a web.conf in your app 
$Splunk_home\Splunk\etc\apps\yourapp\local\web.conf (where your admin dashboard resides)

with

enable_risky_command_check_dashboard=false

This should disbale the warning there.

0 Karma

jotne
Communicator

It did not work.

When I did make a web.conf file like this in one app, it disabled the warning in all apps.

[settings]
enable_risky_command_check_dashboard = false

 

0 Karma
Get Updates on the Splunk Community!

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...

Five Subtly Different Ways of Adding Manual Instrumentation in Java

You can find the code of this example on GitHub here. Please feel free to star the repository to keep in ...

New Splunk APM Enhancements Help Troubleshoot Your MySQL and NoSQL Databases Faster

Splunk Observability has two new enhancements to make it quicker and easier to troubleshoot slow or frequently ...