Splunk Enterprise

For single value panel need to replace 'no results found' message with custom data



I tried the below logic, to replace the "no results found "message with a custom message.
But after adding append count the,  at end of the query.
logic is not working as expected. Can anyone please help?

base search | fields version, time  | appendpipe [stats count | where count=0]
    <condition match=" 'job.resultCount' == 0">
        <set token="show_html">true</set>
        <unset token="show_html"/>
<chart rejects="$show_html$">
<html depends="$show_token$">
     <div style="font-weight:bold;font-size:150%;text-align:center;color:red">
          No data, Please check later


Labels (2)
Tags (4)
0 Karma


@kirruskDid you get a zero at the end of your query? Or are you still trying to do that?
If you do have a "0" at the end of your query, then it is as easy as modifying your last line to


| appendpipe 
    [ stats count 
    | where count=0 
    | eval count="No data, Please check later"]

I tested this and it will display in a single value viz. So you won't need any of the custom xml, because the logic is in the query itself.



If this reply helps you, an upvote would be appreciated.
0 Karma


@efavreau Thank you, but it is not exactly what I'm looking for. I'm using the hyper link. So if there is no data also hyperlink is still enabled on custom message, which should not.

0 Karma
Get Updates on the Splunk Community!

Set Up More Secure Configurations in Splunk Enterprise With Config Assist

This blog post is part 3 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Enterprise Security Content Update (ESCU) v3.54.0

The Splunk Threat Research Team (STRT) recently released Enterprise Security Content Update (ESCU) v3.54.0 and ...