Splunk Enterprise Security

My Key Security Indicators aren't working after removing the default "admin" account (display "Unable to load results")

LukeMurphey
Champion

I recently removed the default "admin" account and am now finding that the Key Indicators no longer work. Are these related? Does ES require the admin user to exist?

0 Karma
1 Solution

LukeMurphey
Champion

ES does require that the "admin" account exist. By default, saved searches use "dispatchAs" setting of "owner". The owner of the searches is set to "admin" via default.meta.

Thus, removing the admin user will cause searches to fail. If the admin user to removed, then the following error will be observed when searches are executed that attempt to run under the admin user:

'DispatchManager': The user 'admin' does not have sufficient search privileges.

To fix this issue, restore the admin user. The searches should begin working immediately (no restart required).

View solution in original post

0 Karma

LukeMurphey
Champion

ES does require that the "admin" account exist. By default, saved searches use "dispatchAs" setting of "owner". The owner of the searches is set to "admin" via default.meta.

Thus, removing the admin user will cause searches to fail. If the admin user to removed, then the following error will be observed when searches are executed that attempt to run under the admin user:

'DispatchManager': The user 'admin' does not have sufficient search privileges.

To fix this issue, restore the admin user. The searches should begin working immediately (no restart required).

View solution in original post

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!