Splunk Dev

When will Splunk DB Connect support Java 8?

pmdba
Builder

Currently DB Connect documentation states that it only works with Java 6 (already past end-of-life) and Java 7 (end-of-life in April 2015). Our organization will not allow Java 7 apps on our network once security patches are no longer available for it. Does anyone at Splunk know when support for Java 8 will be available?

1 Solution

ChrisG
Splunk Employee
Splunk Employee

The dev team is working on this for an upcoming release. I can't give specific dates, but the work is in progress right now.

View solution in original post

ChrisG
Splunk Employee
Splunk Employee

The dev team is working on this for an upcoming release. I can't give specific dates, but the work is in progress right now.

jcoates_splunk
Splunk Employee
Splunk Employee

And that release is now released at http://splunkbase.splunk.com/app/2686/
DB Connect v1 needs Java 7
DB Connect v2 needs Java 8

ShaneNewman
Motivator

I am using Splunk DB Connect with JRE 8 right now, I have no issues. We have been running JRE 8 for about 3 or 4 months with no issues.

dave_maclean
Explorer

While Shane might not be having any issues, according to Splunk, Java 8 is still not supported. See their documentation as well as this item:

http://answers.splunk.com/answers/179701/splunk-db-connect-why-am-i-getting-an-error-config.html

So I'd also like to know the real answer to the above question: when will DBX support Java 8? Thank you.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...