Splunk Cloud Platform

Not able to hit webhook through Splunk Cloud instance.


Hello All,

We added Webhook as one of the action item for Splunk report. But whenever search criteria is met we are not getting any hit on webhook. So we tried adding one more simple action which is mail alert. Surprisingly I m receiving a mail once search criteria is met but no any hit on webhook.

Webhook url is deployed in our internal network so are we supposed to open Firewall for Splunk cloud instance url? Also do Splunk team needs to add our internal IP any where? Please provide your valuable suggestion to get it worked.

Please note that we are using Splunk cloud instance.

Thanks in advance,



Labels (2)
0 Karma


If you do not open your firewall then how will the webhook URL be reached?  Contact Splunk Cloud Support for assistance as they may need to do something on their end as well.

If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

Avoid Certificate Expiry Issues in Splunk Enterprise with Certificate Assist

This blog post is part 2 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Using Machine Learning for Hunting Security Threats

REGISTER NOW Seeing the exponential hike in global cyber threat spectrum, organizations are now striving more ...

Security Highlights | November 2022 Newsletter

 November 2022 2022 Gartner Magic Quadrant for SIEM: Splunk Named a Leader for the 9th Year in a RowSplunk is ...