Security

searchbnf configuration always puts an 'equal' after the suggestions

jschoenberg_spl
Splunk Employee
Splunk Employee

In Splunk I have configured the searchbnf.conf to provide some helpful search hints inline while the person types SPL. It works pretty good, with each search option coming up in green as a suggestion. However, the suggestions always have an equal sign after the option is found. For instance, the custom search I created is runmycmd, and it has the option of trigger, then a host= parameter for the user to use in SPL. The right way to use it is like this | runmycmd trigger host=mylinuxmachine.

In my searchbnf.conf I am specifying that trigger is an option top the runmycmd command, but it always wants to put an equal sign. Is there a different option here that restricts the help to just a parameter name rather than a name=value pair?

[runmycmd-command]
syntax = runmycmd | |
shortdesc = Executes a request of your environment to bring data in. This command includes several operators.
description = Uses this method to retrieve data
usage = public
example1 = | runmycmd trigger host=mylinuxmachine
comment1 = In this example if you find a trigger that is on a host named mylinuxmachine

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!