Security

User Does Not Appear in Job Management Dropdown

I_am_Jeff
Communicator

I have a user (maybe more) that submitted a job to the background. When he went to look for his job, he couldn't find his name in the Owner dropdown box on the Jobs page. I can find his jobs when using his name in the generic search text box, the one next to the magnifying glass icon. Same behavior on both IE and Firefox.

  1. Any idea how to add him into the Owner dropdown?
  2. Or at least why he doesn't appear there?

Manager >> Access controls > Users says I have 460 items. Splunk 4.1.5, Solaris 10.

Tags (2)
0 Karma
1 Solution

MuS
SplunkTrust
SplunkTrust

Hi I am Jeff

just tested it and created 500 users, they are listed in user manager BUT only the first 250 users are listed in Jobs.

This default can be changed in etc\system\default\data\ui\views\job_management.xml with the following strings:

<param name="label">Owner</param>
<param name="settingToCreate">owner_setting</param>
<param name="count">250</param>

To make this change persistent over update copy the file into etc\system\local\data\ui\views\ and change the default of 250 to what ever you want.

On the other hand if you do this, you must remember to check after every update if the file in etc\system\default\data\ui\views\ has changed. If so you have to update the file in etc\system\local\data\ui\views\ as well. You have to change either job_management.xml file after each update - so you can do it either way.

hope this helps

regards

View solution in original post

MuS
SplunkTrust
SplunkTrust

Hi I am Jeff

just tested it and created 500 users, they are listed in user manager BUT only the first 250 users are listed in Jobs.

This default can be changed in etc\system\default\data\ui\views\job_management.xml with the following strings:

<param name="label">Owner</param>
<param name="settingToCreate">owner_setting</param>
<param name="count">250</param>

To make this change persistent over update copy the file into etc\system\local\data\ui\views\ and change the default of 250 to what ever you want.

On the other hand if you do this, you must remember to check after every update if the file in etc\system\default\data\ui\views\ has changed. If so you have to update the file in etc\system\local\data\ui\views\ as well. You have to change either job_management.xml file after each update - so you can do it either way.

hope this helps

regards

View solution in original post

I_am_Jeff
Communicator

For the record, we implemented a new instance of Splunk and this also works on Red Hat. Not that I had any doubts.

0 Karma

I_am_Jeff
Communicator

This nailed it. job_management.xml had the information.

I copied it to .../local/data/ui/views/job_management.xml (had to create the last few directories first.), modified the "count" parameter and restarted. My user can now see himself.

THANK YOU!

0 Karma

MuS
SplunkTrust
SplunkTrust

Hi I am Jeff updated my answer - check it out 🙂

0 Karma

I_am_Jeff
Communicator

Yup. Most users are already there. I didn't count to see how many are missing, though. Some random user doesn't seem to be added to the list. The missing user is a long time user, not someone I just added. I'm wondering if 450 users overflows a list somewhere.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.