Installation

'Report Acceleration' Missing in Manager

rgcurry
Contributor

I am testing Splunk 5.0.5 for our next upgrade. I am currently testing Report Acceleration and have created a new search from which I am starting this part of this work. After saving the search and setting it to use Report Acceleration, I went to Manager and do not see "Report Acceleration" as an option. The upgrade went without error and this is the first problem like this that I've seen. Is there a setting that needs made or a config that needs edited? Please advise.

Labels (1)
0 Karma
1 Solution

rgcurry
Contributor

This is long overdue -- my apologies for not posting this well over a year ago.

The cause of this problem was a matter of placement. We use Search Head Pooling but we use a script to rsync our search heads pooling area of the file system. The install process naturally does not recognize our pooling structure so the required code to provide the menu/links for this was not copied into the pooling area. That being so, the web interface does not have access to it since it too pulls from this pooling area. Modifying the install process to copy what was missing (etc/apps/search/(appserver|bin|default|scripts|metadata/default.meta) resolved this problem.

Now that many of us have or will soon move to v6, this is probably not so helpful. If anyone is still at v4.x, get to v5(current) now! You’ll be glad you did.

View solution in original post

0 Karma

rgcurry
Contributor

This is long overdue -- my apologies for not posting this well over a year ago.

The cause of this problem was a matter of placement. We use Search Head Pooling but we use a script to rsync our search heads pooling area of the file system. The install process naturally does not recognize our pooling structure so the required code to provide the menu/links for this was not copied into the pooling area. That being so, the web interface does not have access to it since it too pulls from this pooling area. Modifying the install process to copy what was missing (etc/apps/search/(appserver|bin|default|scripts|metadata/default.meta) resolved this problem.

Now that many of us have or will soon move to v6, this is probably not so helpful. If anyone is still at v4.x, get to v5(current) now! You’ll be glad you did.

0 Karma

ChrisG
Splunk Employee
Splunk Employee

Are you looking in Manager > Searches and reports? or are you looking for Manager > Report Acceleration Summaries and it's not there? If it is the latter, note that you can only access the Report Acceleration Summaries page in Manager if your role enables you to accelerate reports (your role must have the schedule_search capability).

rgcurry
Contributor

I am looking for Manager > Report Acceleration and I am an admin on the system. I saved a search and checked the box for report acceleration for it. When I attempted to verify the summary index was being built for it, I discovered the missing option.

0 Karma
Get Updates on the Splunk Community!

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Avoid Certificate Expiry Issues in Splunk Enterprise with Certificate Assist

This blog post is part 2 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Using Machine Learning for Hunting Security Threats

REGISTER NOW Seeing the exponential hike in global cyber threat spectrum, organizations are now striving more ...