Installation

Machine learning toolkit (MAC) fit error

leonradams
Explorer

I am using a MAC and have installed the Python for Scientific computing (DARWIN). Then installed the Machine learning toolkit. Running the Linear regression showcase fails at the Fitting Model step with following Error message:

Error in 'fit' command: Failed to find Python for Scientific Computing Add-on (Splunk_SA_Scientific_Python_linux_x86_64)

Why is there a linux Scientific Python dependency for the Machine learning toolkit. Is there a mac specific machine learning toolkit?

Tags (1)
0 Karma
1 Solution

leonradams
Explorer

Found and answer going back to the installation. I am working with the docker image of splunk/latest on a MAC book. Turns out that the splunk image requires the linux version of the Python for scientific computing. Steps taken:

  1. rm installed docker image
  2. pulled new docker splunk image
  3. run the new docker splunk image
  4. install the linux version of Python for Scientific computing
  5. install the machine learning toolkit

View solution in original post

0 Karma

leonradams
Explorer

Found and answer going back to the installation. I am working with the docker image of splunk/latest on a MAC book. Turns out that the splunk image requires the linux version of the Python for scientific computing. Steps taken:

  1. rm installed docker image
  2. pulled new docker splunk image
  3. run the new docker splunk image
  4. install the linux version of Python for Scientific computing
  5. install the machine learning toolkit

View solution in original post

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!