Installation

Installing Splunk Universal Forwarder on Windows 2008 and getting error

Abdullah
Engager

Hi,

I tried to install Splunk UF on windows server 2008, but appeared error.

You can see the error in the screen shot. 

 

Please your support.

 

Thankserror3.JPG.png

 

Labels (2)
0 Karma

Abdullah
Engager

Hi,

The version for Splunkforwarder that I tried to install it is 6.6.12.1, but appeared the same error.

 

Regards,

0 Karma

PickleRick
Ultra Champion

I have no knowledge about requirements for 6.6.12.1 version of UF nor have I access to relevant documentation for that old product. It might as well also be a 2008R2 "upwards" release.

As I said - your last chance here is support.

0 Karma

Abdullah
Engager

Hi,

Thank you.

I tried to install Splunk version 6.X.X, the same error appeared, but the same first error.

 

Regards

0 Karma

PickleRick
Ultra Champion

Are you sure the the version you're installing supports the windows 2008 release? It's so outdated I cannot find any official information on the web at this moment. As I said before - if you really need a version for that old version, you can file a support case to get access to a sufficiently old version to support w2008 but noone will help you with it if anything goes wrong.

0 Karma

PickleRick
Ultra Champion

As the error message clearly says - you're trying to install a version of forwarder which does not support that old version of Windows. You might try older UF version as long as it is compatible with your indexers - see https://docs.splunk.com/Documentation/VersionCompatibility/current/Matrix/Compatibilitybetweenforwar...

See https://www.splunk.com/en_us/download/previous-releases/universalforwarder.html for a version supporting Win 2008 (only 2008R2 are supported for 7.x).

If you need even older forwarder, you'll have to file a support case.

0 Karma

Abdullah
Engager

Thanks Mr.

 

Already I tried to install version 7.x.x but appeared this error in screen shot.

 

error4.PNG

 

Tags (1)
0 Karma

PickleRick
Ultra Champion

This time you probably tried to install 64-bit version on a 32-bit system. This means you have a 2008, not 2008R2 which was 64-bit only.

That in turn means that you need an even older forwarder which you might be able to obtain from the support team directly. But bear in mind that there is no support for 6.x forwarders with any newer (7.x+) indexers (even though they should work, but noone will bother if something doesn't work).

To put it bluntly - it's a 14-years old system, already two years past the most extended support, and it should already be scrapped.

0 Karma
Get Updates on the Splunk Community!

BSides Splunk 2022 - The Call for Papers is now Open!

TLDR; Main Site: https://bsidessplunk.com CFP Site: https://bsidessplunk.com/cfp CFP Opens: December 15th, ...

Sending Metrics to Splunk Enterprise With the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

What's New in Splunk Cloud Platform 9.0.2208?!

Howdy!  We are happy to share the newest updates in Splunk Cloud Platform 9.0.2208! Analysts can benefit ...