Getting Data In

ui_inactivity_timeout - web.conf

fisuser1
Contributor

has anyone successfully implemented user session timeouts on their SHC? We are experiencing users keeping multiple dashboards open, sometimes overnight, with multiple panels refreshing which is creating unnecessary load to the SHC. I've set the sessionTimeout to 15 minutes in the server.conf, however this does not seem to boot the user session since the dashboard refreshes every 5-10 minutes. Wondering if anyone had any success booting user sessions over 15-20 minutes due to inactivity by updating corresponding timeouts in the web.conf?

Possible solution?
web.conf
[settings]
tools.sessions.timeout = 15
ui_inactivity_timeout = 15

server.conf
[general]
sessionTimeout = 900s

joshualemoine
Path Finder

Same issues, with nearly the same settings. The only thing different in my settings are as follows:

web.conf
[settings]
tools.sessions.timeout = 15
ui_inactivity_timeout = 5

server.conf
[general]
sessionTimeout = 900s

As I understand it from the documentation, Splunk is SUPPOSED to kick them out after the sum of "tools.sessions.timeout + ui_inactivity_timeout," so in my case, 20-minutes, but it still lasts the default of 60-minutes. I've restarted splunkd, and ensured with btool that the settings are applied to the entire SHC. Not sure what to do and Compliance is pushing us to get this fixed!

0 Karma
Get Updates on the Splunk Community!

Ready, Set, SOAR: How Utility Apps Can Up Level Your Playbooks!

 WATCH NOW Powering your capabilities has never been so easy with ready-made Splunk® SOAR Utility Apps. Parse ...

DevSecOps: Why You Should Care and How To Get Started

 WATCH NOW In this Tech Talk we will talk about what people mean by DevSecOps and deep dive into the different ...

Introducing Ingest Actions: Filter, Mask, Route, Repeat

WATCH NOW Ingest Actions (IA) is the best new way to easily filter, mask and route your data in Splunk® ...