Getting Data In

Why is my Splunk Web URL not working?

rsingh
Explorer

if i enter this url https://localhost:8001/ i get the snapshot below

alt text

here is my web.conf

[settings]
enableSplunkWebSSL = 1
privKeyPath = 
serverCert = 
startwebserver =1
mgmtHostPort = 192.168.101.148:8001

splunk-launch.conf

# Splunkweb service name
SPLUNK_WEB_NAME=splunkweb
SPLUNK_BINDIP=192.168.101.148:8001

i have a Windows 2008 Server and my Splunk version is 6.5.1

0 Karma
1 Solution

dmaislin_splunk
Splunk Employee
Splunk Employee

Because you have a port added to the SPLUNK_BINDIP

http://docs.splunk.com/Documentation/Splunk/6.5.1/Admin/BindSplunktoanIP

If you want this to be a permanent change in your working environment, modify $SPLUNK_HOME/etc/splunk-launch.conf to include the SPLUNK_BINDIP attribute and value. For example, to bind Splunk ports to 127.0.0.1 (for local loopback only), splunk-launch.conf should read:

Modify the following line to suit the location of your Splunk install.

If unset, Splunk will use the parent of the directory this configuration

file was found in

SPLUNK_HOME=/opt/splunk

SPLUNK_BINDIP=127.0.0.1
Important: The mgmtHostPort attribute in web.conf has a default value of 127.0.0.1:8089. Therefore, if you change SPLUNK_BINDIP to any value besides 127.0.0.1, you must also change mgmtHostPort to use the same IP address. For example, if you make this change in splunk-launch.conf:

SPLUNK_BINDIP=10.10.10.1
you must also make this change in web.conf (assuming the management port is 8089):

mgmtHostPort=10.10.10.1:8089

View solution in original post

dmaislin_splunk
Splunk Employee
Splunk Employee

Because you have a port added to the SPLUNK_BINDIP

http://docs.splunk.com/Documentation/Splunk/6.5.1/Admin/BindSplunktoanIP

If you want this to be a permanent change in your working environment, modify $SPLUNK_HOME/etc/splunk-launch.conf to include the SPLUNK_BINDIP attribute and value. For example, to bind Splunk ports to 127.0.0.1 (for local loopback only), splunk-launch.conf should read:

Modify the following line to suit the location of your Splunk install.

If unset, Splunk will use the parent of the directory this configuration

file was found in

SPLUNK_HOME=/opt/splunk

SPLUNK_BINDIP=127.0.0.1
Important: The mgmtHostPort attribute in web.conf has a default value of 127.0.0.1:8089. Therefore, if you change SPLUNK_BINDIP to any value besides 127.0.0.1, you must also change mgmtHostPort to use the same IP address. For example, if you make this change in splunk-launch.conf:

SPLUNK_BINDIP=10.10.10.1
you must also make this change in web.conf (assuming the management port is 8089):

mgmtHostPort=10.10.10.1:8089

View solution in original post

rsingh
Explorer

whats the best way to push out updated input and output files?

0 Karma

coltwanger
Contributor

Just like you said, use a deployment server. Create a server class, add an app with your input.conf and output.conf, and add servers to that class.

0 Karma

rsingh
Explorer

can my splunk server be a deployment server also?

if i build a distribution server will it help me edit and distribute my input.conf and output.conf files

0 Karma

coltwanger
Contributor

Yes, any Splunk instance can be configured to act as a deployment server. If you're building out a distributed environment, it's recommended to have a standalone deployment server, instead of sharing it on an instance that also acts as a Search Head.

0 Karma

rsingh
Explorer

my mgmt port and my Splunk Bind IP port numbers are the same

0 Karma

coltwanger
Contributor

This is your problem, because you're hitting the REST interface (which sits on the management port). Use two different ports for web access and management.

rsingh
Explorer

Genius - that worked. thanks

i have a dns name i would like to add to the server - nxsplunk.domain.com

i made the change in the Server settings but still cannot get to the name. can you point me to where else i need to add/change the name

thanks again

0 Karma

rsingh
Explorer

i got it working with the Splunk_BindIP

0 Karma

aaraneta_splunk
Splunk Employee
Splunk Employee

@rsingh - Just so you know, I edited your post to reflect your screenshot which shows you're currently using Splunk version 6.5.1 (rather than 6.5.0 as you originally noted).

0 Karma

rsingh
Explorer

my mistake - take a lot @aaraneta

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!