Getting Data In

Why am I getting cooked mode v3 data testing TCP input on Universal Forwarder?

jcbfaulks
Explorer

I'm not exactly sure what is going on but when I installed universal forwarder and the receiver my splunk is getting this as data.

--splunk-cooked-mode-v3--\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00IT-CON-178\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x008089\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00@\x00\x00\x00\x00\x00\x00__s2s_capabilities\x00\x00\x00\x00ack=0;compression=0\x00\x00\x00\x00\x00\x00\x00\x00_raw\x00

I don't know why its coming out like this on the other end the file is just a regular log file nothing special. I uploaded it before through file/dir inputs now testing the tcp input but this is happening. Anyone can point me in the right direction?

0 Karma
1 Solution

martin_mueller
SplunkTrust
SplunkTrust

Make sure your Splunk indexer has receiving turned on (splunktcp in inputs.conf, Settings -> Forwarding and Receiving -> Configure Receiving in the UI) for cooked data from Splunk forwarders rather than just listening on a tcp port (tcp in inputs.conf, Settings -> Data Inputs -> TCP in the UI) for raw data.

http://docs.splunk.com/Documentation/Splunk/6.1.4/Forwarding/Enableareceiver

View solution in original post

martin_mueller
SplunkTrust
SplunkTrust

Make sure your Splunk indexer has receiving turned on (splunktcp in inputs.conf, Settings -> Forwarding and Receiving -> Configure Receiving in the UI) for cooked data from Splunk forwarders rather than just listening on a tcp port (tcp in inputs.conf, Settings -> Data Inputs -> TCP in the UI) for raw data.

http://docs.splunk.com/Documentation/Splunk/6.1.4/Forwarding/Enableareceiver

jcbfaulks
Explorer

I didn't set up the receiver but it was gone for some reason. . . dammit. Thanks

0 Karma
Get Updates on the Splunk Community!

What’s new on Splunk Lantern in August

This month’s Splunk Lantern update gives you the low-down on all of the articles we’ve published over the past ...

Welcome to the Future of Data Search & Exploration

You have more data coming at you than ever before. Over the next five years, the total amount of digital data ...

This Week's Community Digest - Splunk Community Happenings [8.3.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...