Getting Data In

Search in the earliest source

ryastrebov
Communicator

Hello!
I have sourtsetype that contains multiple source. Into sourcetype permanently add new source. I need to search in the earliest source. For extract most earliest source I use this search request:

sourcetype="MySourceType" source=* NOT [ | inputlookup usedfiles.csv|fields source]| stats dc(source) by source | sort 1 by source | fields - dc(source) | outputlookup append=true usedfiles.csv

This search successfully return of earliest source name. How I can make search into this source? This search request is not working:

sourcetype="MySourceType" source=* NOT [ | inputlookup usedfiles.csv|fields source]| stats dc(source) by source | sort 1 by source | fields - dc(source) | outputlookup append=true usedfiles.csv | search Field="value"
Tags (2)
0 Karma
1 Solution

jstockamp
Communicator

I would think you could just use the "earliest" function of stats - i.e.

sourcetype="mysourcetype" | stats earliest(source) as firstsource | search source=firstsource

View solution in original post

jstockamp
Communicator

I would think you could just use the "earliest" function of stats - i.e.

sourcetype="mysourcetype" | stats earliest(source) as firstsource | search source=firstsource

ryastrebov
Communicator

Thank you!
And as the search will proceed to the next source?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...