Getting Data In

How to configure a forwarder so it does not forward any data that appeared while the forwarder was stopped?

ayushchoudhary
Path Finder

Sometimes due to a space issue, we have to stop the forwarder from sending data to Splunk.
However, when we start the forwarder, it sends the data which was not indexed during the time it was stopped.

Our requirement is, when we start the forwarder, it should not send the un-indexed data and just start sending fresh data to Splunk.

0 Karma
1 Solution

ChrisG
Splunk Employee
Splunk Employee

Do you have indexer acknowledgment enabled in outputs.confon the forwarder? It is disabled by default, but from your description of the behavior, it sounds as if it is enabled. See Protect against loss of in-flight data in the Forwarding Data manual.

View solution in original post

0 Karma

ChrisG
Splunk Employee
Splunk Employee

Do you have indexer acknowledgment enabled in outputs.confon the forwarder? It is disabled by default, but from your description of the behavior, it sounds as if it is enabled. See Protect against loss of in-flight data in the Forwarding Data manual.

0 Karma
Get Updates on the Splunk Community!

Routing Data to Different Splunk Indexes in the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

Getting Started with AIOps: Event Correlation Basics and Alert Storm Detection in ...

Getting Started with AIOps:Event Correlation Basics and Alert Storm Detection in Splunk IT Service ...

Register to Attend BSides SPL 2022 - It's all Happening October 18!

Join like-minded individuals for technical sessions on everything Splunk!  This is a community-led and run ...