Developing for Splunk Enterprise

check_reload_trigger_for_all_custom_confs - app inspect error for .conf file

altink
Contributor

At App Inspect Report the following error comes out for my application:

check_reload_trigger_for_all_custom_confs
Custom conf file inputs_templates.conf does not have a reload trigger in app.conf. Without a reload trigger the app will request a restart on any change to the conf file, which may be a negative experience for end-users.

My app does indeed have a .conf template file under default, named inputs_templates.conf. Under this same folder (/default), the following is the content of my app.conf:

 

 

[default]

[install]
is_configured = 0

[launcher]
author = DATAPLUS - Altin Karaulli
description = Omega Core Audit for Oracle App for Splunk is a security solution for Oracle databases.
version = 1.8.2

[package]
check_for_updates = 1
id = omega_core_audit

[ui]
label = Omega Core Audit for Oracle
is_visible = 1

[triggers]
reload.inputs_templates.conf = simple

 


Note the reload.inputs_templates.conf = simple under [triggers].

So why the failure by App Inspect ?

best regards
Altin


Labels (1)
Tags (1)
0 Karma
1 Solution

sloshburch
Splunk Employee
Splunk Employee
Oh my. Brace yourself but this may be a very silly one. Try removing ".conf" from the app.conf trigger stanza that you set to 'simple'. I have a scary feeling that will be all.  The inclusion of the '.conf' is probably triggering the following app.conf setting which means that this is looking for the 'conf' stanza within the respective filename.
reload.<conf_file_name>.<conf_stanza_prefix> - https://docs.splunk.com/Documentation/Splunk/latest/Admin/Appconf

View solution in original post

0 Karma

sloshburch
Splunk Employee
Splunk Employee
Oh my. Brace yourself but this may be a very silly one. Try removing ".conf" from the app.conf trigger stanza that you set to 'simple'. I have a scary feeling that will be all.  The inclusion of the '.conf' is probably triggering the following app.conf setting which means that this is looking for the 'conf' stanza within the respective filename.
reload.<conf_file_name>.<conf_stanza_prefix> - https://docs.splunk.com/Documentation/Splunk/latest/Admin/Appconf
0 Karma

altink
Contributor

Thank You very much for the help (and the solution) @sloshburch 

best regards
Altin

0 Karma

altink
Contributor

Thank you very much @sloshburch 

I did check more carefully the app.conf syntax, and I found the following:

[triggers]
########## Conf-level reload triggers ##########
# Do not force a restart of Splunk Enterprise for state changes of MyApp
# Do not run special code to tell MyApp to reload myconffile.conf
# Apps with custom config files usually pick this option:
reload.myconffile = simple

Indeed the extension .conf is not present in the file naming

So I should make my declaration as:

[triggers]
reload.inputs_templates = simple

correct?

best regards
Altin

0 Karma

sloshburch
Splunk Employee
Splunk Employee

That's what I'm thinking. Only one way to find out... 😉

Build the package and toss it in AppInspect to see. https://dev.splunk.com/enterprise/docs/developapps/testvalidate/appinspect/

Good luck!

0 Karma

altink
Contributor

On this issue Github
https://github.com/guilhemmarchand/TA-jira-service-desk-simple-addon/issues/104
says:

Add in app.conf:
[triggers]
reload.ta_service_desk_simple_addon_settings = simple

I did that:

[triggers]
reload.inputs_templates.conf = simple

but still I have the Failure in Splunkbase for my app

0 Karma

altink
Contributor

... talking about AppInspect Report produced online in Splunkbase, under "Manage App"
No install of the appinspect in my Splunk.splunk_appinspect_error.png

0 Karma