Developing for Splunk Enterprise

User does not exist error

mvdobrinin
Engager

I am seeing an error when attempting to use the REST API.

curl -X POST https://localhost:8089/servicesNS/admin/search/data/indexes -u splunkadmin:splunkadmin -d name=myindexname -k

The given request gives me an error about a completely different user.

<?xml version="1.0" encoding="UTF-8"?>
<response>
  <messages>
    <msg type="ERROR">User does not exist: admin</msg>
  </messages>
</response>

Looking at the configuration in Splunk Web, I don't even see such a user configured.

alt text

The version is as follows.
Splunk Enterprise
Version: 7.2.6
Build: c0bf0f679ce9

Any idea what's going on?

Tags (1)
0 Karma
1 Solution

VatsalJagani
Motivator

Hi @mvdobrinin,

curl -X POST https://localhost:8089/servicesNS/splunkadmin/search/data/indexes -u splunkadmin:splunkadmin -d name=myindexname -k
In url also you need to use splunkadmin as you do not have admin user.

View solution in original post

VatsalJagani
Motivator

Hi @mvdobrinin,

curl -X POST https://localhost:8089/servicesNS/splunkadmin/search/data/indexes -u splunkadmin:splunkadmin -d name=myindexname -k
In url also you need to use splunkadmin as you do not have admin user.

View solution in original post

mvdobrinin
Engager

Thanks for the quick reply. That was the issue. The docs here were not clear on that.

0 Karma

VatsalJagani
Motivator

@mvdobrinin - In servicesNS/admin/search/, admin is user-name and search is app-name.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!