Deployment Architecture

SHC Deployer not showing up in the Monitoring Console overview

Robbie1194
Communicator

Hi guys,

I've just set up a new SHC with the label shcluster1. Each search head and the deployer have this label. I've checked server.conf and can see it's definitely on all components of the SHC, yet the MC still doesn't pick this label up or display the Deployer on the overview screen.

I've added the deployer (and all search heads) as search peers of the MC so it knows the deployer's there as it lists it in the set up, however, it doesn't appear as a panel in the overview still! I can manually assign it the tag in the MC but it still won't display the machine in the overview.

Has anyone else ever had this problem or know what I can do to fix it?

Thanks,

0 Karma

gcusello
Legend

Hi Robbie1194,
did you tried to send Deployer's logs to the indexers?
In my architecture, I have the MC on the same server of Deployer so my MB sees itself as one of the Clustered Search Head.

Bye.
Giuseppe

0 Karma

harsmarvania57
SplunkTrust
SplunkTrust

Hi @Robbie1194,

Once you added the Search Head and Deployer as search peer on MC after that have you configured those new servers in Settings -> General Setup in MC?

0 Karma
Get Updates on the Splunk Community!

Register to Attend BSides SPL 2022 - It's all Happening October 18!

Join like-minded individuals for technical sessions on everything Splunk!  This is a community-led and run ...

What's New in Splunk Cloud Platform 9.0.2208?!

Howdy!  We are happy to share the newest updates in Splunk Cloud Platform 9.0.2208! Analysts can benefit ...

Admin Console: A Single, Unified Interface for All Your Cloud Admin Needs

WATCH NOWJoin us to learn how the admin console can save you time and give you more control over the Splunk® ...