Deployment Architecture

Management port already in use

Rocky31
Path Finder

What if mgmt port is not available is there any alternative, do i need to change whole setting if i change the mgmt port, what if i choose to change mgmt port what if i hit "y" in the end please suggest me

opt/splunk/bin/splunk status
splunkd is not running

/opt/splunk/bin/splunk start
Checking prerequisites...
Checking http port [8000]: open
Checking mgmt port [8090]: not available
ERROR: mgmt port [8090] - port is already bound. Splunk needs to use this port.
Would you like to change ports? [y/n]:

0 Karma
1 Solution

splunk_sv
Path Finder

I have recently faced this issue when I was setting up my Splunk server on a remote machine.
Sometimes it happens that the port you want to use is already in use by other service or it is not available to the user which you are using to start Splunk. In that case, you either need to change the port or the user.

There is not much of a setting you need to change, you can use the following ways to change the mgmt port,
1. Change the management port using CLI,

splunk set  splunkd-port 9089

Source:
https://docs.splunk.com/Documentation/Splunk/7.2.6/Admin/Changedefaultvalues
2. Change the management port by updating the configuration file(web.conf),
You will find the below line in the conf file and update it with the port of your choice,

mgmtHostPort = 127.0.0.1:9089

Hope it helps!

View solution in original post

0 Karma

splunk_sv
Path Finder

I have recently faced this issue when I was setting up my Splunk server on a remote machine.
Sometimes it happens that the port you want to use is already in use by other service or it is not available to the user which you are using to start Splunk. In that case, you either need to change the port or the user.

There is not much of a setting you need to change, you can use the following ways to change the mgmt port,
1. Change the management port using CLI,

splunk set  splunkd-port 9089

Source:
https://docs.splunk.com/Documentation/Splunk/7.2.6/Admin/Changedefaultvalues
2. Change the management port by updating the configuration file(web.conf),
You will find the below line in the conf file and update it with the port of your choice,

mgmtHostPort = 127.0.0.1:9089

Hope it helps!

View solution in original post

0 Karma

woodcock
Esteemed Legend

Either kill/move the existing process (it quite likely is a zombie splunk process anyway) or configure splunk to use another port.

adonio
SplunkTrust
SplunkTrust

many answers in this portal, below are 2 different approaches, one is to change the port and the other is to do what is needed to free the port for splunk use

https://answers.splunk.com/answers/511000/how-to-resolve-error-error-the-mgmt-port-8089-is-a.html
https://answers.splunk.com/answers/579726/what-can-be-done-when-port-8089-is-taken-on-the-fo.html

hope it helps

.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!