Deployment Architecture

Bucket replication issues - No possible srcs for replication

damode
Motivator

I have approx. 35k buckets under Fixup Tasks Pending (35k).

  1. Under Fixup Category Search Factor
    1. Current Status - Missing enough suitable candidates to create searchable copy in order to meet replication policy. Missing={ default:1 }
    2. Time in Fixup - 17 hour(s) 8 minute(s)
    3. Fixup Reason -  unmet rf
  2. Under Fixup Category Replication Factor
    1. Status - No possible srcs for replication
    2. Time in Fixup - 17 hour(s) 8 minute(s)
    3. Fixup Reason - unmet rf

Env. details -

  • 3 x Indexers in a cluster, 1 ES, 2 regular non-clustered SHs, 1 DS
  • RF=2
  • SF=2
  • Third indexer was just newly added 4 days ago.

Can someone please advise the cause of these issues and how I can fix this ?

Background - after adding new (third) Indexer, there was some storage issue due to which it went to automatic detention but which we eventually fixed it and brought back to cluster from detention. All Indexers are up and running. After that, to fix the above issue, based on some post I did rolling restart and restarted CM but still no change to the above.

Labels (3)

haraksin
Path Finder

It appears that the best fix for this is to restart the Splunk process on the indexer master - note that restarting via the GUI does not work.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!