All Apps and Add-ons

can't restart splunk on Websphere Application Server/Universal Forwarder

jchilovich
New Member

I have installed the Websphere Applications Server on a Universal Forwarder and had it working, sending to an Indexer on a non-WAS box. The location of the Indexer has now been relocated. Once the Indexer was established, I ran the following 2 commands on the WAS instance:
./splunk set deploy-poll :
./splunk add forward-server : -auth admin:changeme
I then execute a restart and receive the following error. What am I missing here? Nothing has changed as far as I'm aware except for the above two commands exeuted.

bash-3.2$ ./splunk restart
splunkd is not running. WARNING: initlog is deprecated and will be removed in a future release
[FAILED]
Splunk> 4TW

Checking prerequisites...
Checking mgmt port [8089]: open
Could not find platform independent libraries
Could not find platform dependent libraries
Consider setting $PYTHONHOME to [:]
ImportError: No module named site

0 Karma

jchilovich
New Member

I'm posting my comment above as an answer so this shows updated.
Found the issue !! it relates to a python folder found in the splunkforwarder/bin directory. once I rename that folder to '.old', the application will start. This will lead to another question to be posted.
Thanks

0 Karma

jchilovich
New Member

Found the issue !! it relates to a python folder found in the splunkforwarder/bin directory. once I rename that folder to '.old', the application will start. This will lead to another question to be posted. Thanks

0 Karma