All Apps and Add-ons

Tabs Module, Tab Switcher, and TimeSelector

subtrakt
Contributor

Hi!

So i got my dashboard working with 2 tabs and i'm happy. However, when i select the second tab i don't want anything to happen until i click on the timeselector and then submit. I have autorun set to false on all the hidden searches below the timeselector.

Anyone know how i can make the searches in the second tab not run all the searches until i hit the submit button? Right now everything runs when i hit the tab and i dno't want it to run until i hit the submit button.

<module name="Tabs" layoutPanel="panel_row1_col1" autoRun="True"> <param name="name">selectedTab</param> <param name="staticTabs">

<list> <param name="label">test1</param> <param name="value">test1</param> </list>

<list> <param name="label">test2</param> <param name="value">test2</param> </list> </param>

<module name="Switcher" group=" ">
    <param name="selectedGroup">$selectedTab$</param>
     <module name="NullModule" group="test1">

... hidden searches and stuff ...

<module name="NullModule" group="test2">


 <module name="TimeRangePicker" layoutPanel="panel_row2_col1_grp1" autoRun="False">
     <param name="default">Last 15 minutes</param>
     <param name="searchWhenChanged">False</param>
   <module name="SubmitButton" layoutpanel="panel_row2_col1_grp2"> 
     <param name="label">Submit</param> 
     <param name="allowSoftSubmit">False</param> 

Also, i would like to not have the page autorefresh when test2(second tab) is selected but still autorefresh when tab1(first tab) is selected.

1 Solution

sideview
SplunkTrust
SplunkTrust

Replace the Splunk SubmitButton module with the Sideview Button module.
This will allow you to use the Button's allowAutoSubmit param, which is like allowSoftSubmit but different.

You'll want to set both of them to False.

The Button will then block the push on the second tab and thus the user will have to click the green Button on the second tab to run the search(es) therein.

putting autoRun="False" as an attribute into the XML will do nothing in all cases, in that it is exactly the same as putting no autoRun attribute at all.

AutoRun, The Short Version: the attribute should have been called startCascadingPushHereOnPageLoad="true".

Autorun, the long version: download the latest Sideview Utils and read the docs page "introduction to the advanced xml"

View solution in original post

0 Karma

sideview
SplunkTrust
SplunkTrust

Replace the Splunk SubmitButton module with the Sideview Button module.
This will allow you to use the Button's allowAutoSubmit param, which is like allowSoftSubmit but different.

You'll want to set both of them to False.

The Button will then block the push on the second tab and thus the user will have to click the green Button on the second tab to run the search(es) therein.

putting autoRun="False" as an attribute into the XML will do nothing in all cases, in that it is exactly the same as putting no autoRun attribute at all.

AutoRun, The Short Version: the attribute should have been called startCascadingPushHereOnPageLoad="true".

Autorun, the long version: download the latest Sideview Utils and read the docs page "introduction to the advanced xml"

View solution in original post

0 Karma

subtrakt
Contributor

No dice. I noticed this in the URL after the tab is clicked ...#selectedTab&test2&autorun="True"... I Change it to false and it still runs. I'm going to read over this post. http://answers.splunk.com/answers/3792/how-to-disable-autorun-when-switching-tabs

0 Karma

somesoni2
Revered Legend

Try setting autoRun="False" on "Tabs" module.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!