All Apps and Add-ons

Splunk Add-on for IBM Websphere Application Server: Why am I getting was_inputs_gen.py error "ValueError: zero length field name in format"?

mgranger1
Path Finder

I am trying to deploy the Splunk Add-on for IBM Websphere Application Server into our Splunk Enterprise 6.2.3 implementation. I am to the point where I have copied the ibm_was.conf file from the default directory to the local directory and made the necessary changes. We are going to be using the straight log monitor (not the HPEL). Now I am trying to run the python was_inputs_gen.py --was_install_dir /opt/WAS7/WebSphere/ProcServer --index ibm_was command. When I try to run it, I get the following output:

Traceback (most recent call last):
  File "was_inputs_gen.py", line 349, in <module>
    main()
  File "was_inputs_gen.py", line 345, in main
    generate_was_inputs(config)
  File "was_inputs_gen.py", line 337, in generate_was_inputs
    traceback.format_exc())
ValueError: zero length field name in format

I am not a python guy. I'm just an admin who is trying to get this up and running. Any advice?

Thanks,
Matt Granger

0 Karma
1 Solution

mgranger1
Path Finder

Just FYI in case anyone is interested. The errors in the script were caused by the fact that our splunk service user didn't have the appropriate read access to the directory paths needed to by able to read the required log files. Once we granted the appropriate permissions, the script worked like a charm.

View solution in original post

0 Karma

mgranger1
Path Finder

Just FYI in case anyone is interested. The errors in the script were caused by the fact that our splunk service user didn't have the appropriate read access to the directory paths needed to by able to read the required log files. Once we granted the appropriate permissions, the script worked like a charm.

0 Karma

jcoates_splunk
Splunk Employee
Splunk Employee

Hi, does it work when you use the GUI? Manage Apps -> Splunk Add-on for IBM WAS -> Setup, disable HPEL, enable files, click Save?

0 Karma

mgranger1
Path Finder

That simple function works (ie - In the GUI, I can execute those commands), but it didn't run the script to create the inputs file (or at least I can't see a significant inputs.conf in the local directory).

0 Karma