All Apps and Add-ons

SmartStore: Access issue with S3 using HTTPS on NetApp StorageGrid

rbal_splunk
Splunk Employee
Splunk Employee

SmartStore Access issue with S3 using HTTPS on NetApp StorageGrid

NetApp is still having an issue with Splunk SmartStore using the self-signed certificates for SSL/TLS communications to the NetApp StorageGRID.

We are running Splunk on CentOS in the NetApp lab environment. We have copied the StorageGRID public cert into the local CA trust on each of the indexers and ran an update like this:

cp *.pem /etc/pki/ca-trust/source/anchors/ 
update-ca-trust extract 

Still getting SSL/TLS errors since the certificate cannot be verified.

We have been successful with the following tests:
- Connecting Splunk SmartStore to NetApp StorageGRID over http
- Connecting Splunk SmartStore to NetApp StorageGRID with CA signed certificates.

Is Self-signed certificates a problem for us using HTTPS on NetApp StorageGrid?

0 Karma

rbal_splunk
Splunk Employee
Splunk Employee

Here is the configuration that eventually worked.

1)Check if their object store uses v2 and/or v4 signatures, and if v4, does it uses a region settings. It's possible they need to configure the following setting:

remote.s3.auth_region = 
 Optional
 The authentication region to use for signing requests when interacting with the remote storage system supporting the S3 API.
 Used with v4 signatures only.
 If unset and the endpoint (either automatically constructed or explicitly set with remote.s3.endpoint setting) uses an AWS URL 
(for example, https://s3-us-west-1.amazonaws.com), the instance attempts
to extract the value from the endpoint URL (for example, "us-west-1"). See the description for the remote.s3.endpoint setting.
 If unset and an authentication region cannot be determined, the request will be signed with an empty region value.
No default.

2) Managed to o execute splunk rfs command against his Netapp Storagegrid object store, and is able to successfully complete his SmartStore configuration, after adding:
remote.s3.signature_version = v2
remote.s3.clientCert =

Note: "remote.s3.clientCert = " would return null value, which in this case was fine, but same config might work for other Storagegrid env.

indexes.conf stanza for future reference: indexes.conf stanza for future reference:

storagegrid s3 tenant
[volume:splunkdata]
storageType = remote
path = s3://splunkdataprod
remote.s3.access_key =
remote.s3.secret_key =
remote.s3.endpoint = https://:
remote.s3.signature_version = v2
remote.s3.clientCert =

[test]
repFactor=auto
remotePath = volume:splunkdata
homePath=$SPLUNK_DB/test/db
coldPath=$SPLUNK_DB/test/colddb
thawedPath=$SPLUNK_DB/test/thaweddb
maxDataSize = auto
…….

0 Karma
Get Updates on the Splunk Community!

Synthetic Monitoring: Not your Grandma’s Polyester! Tech Talk: DevOps Edition

Register today and join TekStream on Tuesday, February 28 at 11am PT/2pm ET for a demonstration of Splunk ...

Instrumenting Java Websocket Messaging

Instrumenting Java Websocket MessagingThis article is a code-based discussion of passing OpenTelemetry trace ...

Announcing General Availability of Splunk Incident Intelligence!

Digital transformation is real! Across industries, companies big and small are going through rapid digital ...