All Apps and Add-ons

Json ingestion --> Data models Inquiry around best practices

Marius
Engager

Populating a data model with json feed:

One of the fields "mnemonic" looks like this in _raw "mnemonic":"119fw3q-wrl-834v:abc:E10251:2048:119fw3q:You can do it! - TKO"

Strangely the mnemonic field in the data model only captures until the first colon ":"

mnemonic = "119fw3q-wrl-834v"

Does anyone have advise how to get around this without changing the character? Tried some stuff with rex in eval bu _raw is not available for use in eval functions. Thanks in advance

Labels (2)
0 Karma
1 Solution

Marius
Engager

Solved this by using the add via regular expression dropdown option:

\"mnemonic\"\:\"(?<mnemonic>.+?)\",

Give me the Karma Baby

View solution in original post

0 Karma

Marius
Engager

Solved this by using the add via regular expression dropdown option:

\"mnemonic\"\:\"(?<mnemonic>.+?)\",

Give me the Karma Baby

0 Karma
Get Updates on the Splunk Community!

Routing Data to Different Splunk Indexes in the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

Getting Started with AIOps: Event Correlation Basics and Alert Storm Detection in ...

Getting Started with AIOps:Event Correlation Basics and Alert Storm Detection in Splunk IT Service ...

Register to Attend BSides SPL 2022 - It's all Happening October 18!

Join like-minded individuals for technical sessions on everything Splunk!  This is a community-led and run ...