All Apps and Add-ons

DB Connect V3 database input indexes encoded text \ gibberish

lior_g
Explorer

Hello,
I'm having problems with indexing data from a database using DB Connect V3.
I'm able to index the specific database and the results show on my search head, the problem is some values of specific columns which are in Hebrew aren't being shown correctly. They show up as unicode's unknown character symbol -
unicode's unknown character symbol

I've tried adding the following props.conf settings under the search head
[specific_sourcetype]
charset = UTF-8

Still doesn't seem to work.

Thanks.

0 Karma
1 Solution

lior_g
Explorer

Got it.

I added the following parameters to the JVM options (In the same line: -param1 -param2 -param3)
-Dfile.encoding=UTF-8 -DdefaultCharset=UTF-8

Thanks to @cdpascariu who answered it here:
https://answers.splunk.com/answers/511477/how-to-configure-character-set-encoding-when-using-1.html

View solution in original post

0 Karma

lior_g
Explorer

Got it.

I added the following parameters to the JVM options (In the same line: -param1 -param2 -param3)
-Dfile.encoding=UTF-8 -DdefaultCharset=UTF-8

Thanks to @cdpascariu who answered it here:
https://answers.splunk.com/answers/511477/how-to-configure-character-set-encoding-when-using-1.html

0 Karma

lior_g
Explorer

Tried adding the props.conf above under the Heavy Forwarder itself according to this
https://wiki.splunk.com/Where_do_I_configure_my_Splunk_settings%3F
Hebrew still doesn't show up correctly.

0 Karma
Get Updates on the Splunk Community!

Improve Your Security Posture

Watch NowImprove Your Security PostureCustomers are at the center of everything we do at Splunk and security ...

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...