All Apps and Add-ons

Cloud Gateway Status keep showing "Not Connected"

cherryng
New Member

I am setting up connection for the Splunk instance and Splunk Cloud Gateway via a proxy. Proxy server is basically set to allow all, Splunk Cloud Gateway is installed on search head.

According to the guideline in Troubleshoot Splunk Cloud Gateway Connection Issues,
for https connection, it can return "healthy":true

curl https://prod.spacebridge.spl.mobi/health_check  -x http://my_proxy_svr:8000 

for wss connection, it can return 200 and 101 Switching Protocols

curl -i -N -H "Connection: Upgrade" -H "Upgrade: websocket" -H "Host: prod.spacebridge.spl.mobi" -H "Origin: https://prod.spacebridge.spl.mobi"; -H "Authorization: xyz" https://prod.spacebridge.spl.mobi/mobile -x http://my_proxy_svr:8000

However, the status shown in Cloud Gateway Status Dashboard keep showing "Not Connected". For loggings in search, once restarting splunkd, the proxies config is read into program at first but become empty after first "handshake failed" occurred.
alt text

alt text

May I know if there is any clue why cloudgateway is not connected? Thank you.

0 Karma
Get Updates on the Splunk Community!

Improve Your Security Posture

Watch NowImprove Your Security PostureCustomers are at the center of everything we do at Splunk and security ...

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...