All Apps and Add-ons

Cisco Firepower Encore App 4.0.10

harrisoncs
Explorer

Hi,

Last week I upgraded our Splunk servers to 8.1.2. Once completed I upgraded the Cisco Firepower Encore app to 4.0.10. Shortly after data stopped coming in. I did a good bit of troubleshooting including new certs, clean install of the Cisco Encore App, and setting up as new. 

I am currently to the point where I'm getting cisco:estreamer.log (Monitor) every 2 minutes. However, I am NOT getting anything to sourcetype cisco:estreamer:data. When I check the data folder under /splunkhome/etc/apps/TA-estreamer/data it is empty. I do a netstat to my firepower and a ton of data is coming from it. I just can't find where it's landing. I do a search for encore.*.log and nothing shows up. 

Estreamer.conf has the correct information.
Splencore.sh has been configured correctly, tests successfully, and is running.
configure.sh looks correct.  It has this for the path --stream=relfile:///../../data/encore.{0}.log"  which kind've bothers me.  

I'm stuck at the moment.  We are working on restoring a backup of the folder structure before I made the upgrade to have a comparison. 

Any help would be appreciated. If any additional information is needed from me, let me know.

Labels (1)
0 Karma
1 Solution

harrisoncs
Explorer

This is pretty much fixed. There are still some minor issues that I'm deciding whether it worth fixing or not. Problem one for me is on my system 4.0.10 is 100% manual setup. There is no setup option in the GUI anymore, at least for me, and I downloaded it several times and several different versions. Setup went away after version 3.7.4. I did try to use 3.7.4 on 8.1.2 to try the easy way out, but it wouldn't work for me. 

I had to run the commands under splencore.sh to break up the pkcs12 into what was required by Encore. I eventually found this Cisco link that described setting up 4.0.9 in decent detail. 

That link got me to a certain point, but I still didn't have data coming in from the firepower except for status (cisco:estreamer:log). I eventually found a place in place in estreamer.conf that needed to be set to enabled = true.  Then found that app.conf also need is_configured=true, and state=enabled set.  Then data started flowing in, but to the wrong folder.  I ended up just leaving in the folder it was coming to and changing the data folder in all of the conf files. 

 

View solution in original post

0 Karma

harrisoncs
Explorer

This is pretty much fixed. There are still some minor issues that I'm deciding whether it worth fixing or not. Problem one for me is on my system 4.0.10 is 100% manual setup. There is no setup option in the GUI anymore, at least for me, and I downloaded it several times and several different versions. Setup went away after version 3.7.4. I did try to use 3.7.4 on 8.1.2 to try the easy way out, but it wouldn't work for me. 

I had to run the commands under splencore.sh to break up the pkcs12 into what was required by Encore. I eventually found this Cisco link that described setting up 4.0.9 in decent detail. 

That link got me to a certain point, but I still didn't have data coming in from the firepower except for status (cisco:estreamer:log). I eventually found a place in place in estreamer.conf that needed to be set to enabled = true.  Then found that app.conf also need is_configured=true, and state=enabled set.  Then data started flowing in, but to the wrong folder.  I ended up just leaving in the folder it was coming to and changing the data folder in all of the conf files. 

 

0 Karma
Get Updates on the Splunk Community!

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...

Reminder! Splunk Love Promo: $25 Visa Gift Card for Your Honest SOAR Review With ...

We recently launched our first Splunk Love Special, and it's gone phenomenally well, so we're doing it again, ...