All Apps and Add-ons

Add-on Builder stuck on configuration "loading"

kmfpo
Explorer

I am trying to use the Splunk Add-On Builder (v2.2.0) to build a TA to pull data via REST API in Splunk (v7.3.3).  I am not a developer but used it to build the most basic single input configuration setup with a Global Account field.

When I go to my TA (visible) and select Configuration, it stays stuck on "Loading".  I am using a global text box for my API key identifier and token value so in the configuration menu, I am unable to configure this. 

I saw this post here and learned of a dev command.

Output from the developer debug command

 

===================================================
Found scheme="hackerone".
Locating script for scheme="hackerone"...
No regular file="/opt/splunk/etc/apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.sh".
No regular file="/opt/splunk/etc/apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.py".
No regular file="/opt/splunk/etc/apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.js".
No regular file="/opt/splunk/etc/apps/TA-ta-hackerone/linux_x86_64/bin/hackerone".
No script found in dir="/opt/splunk/etc/apps/TA-ta-hackerone/linux_x86_64/bin"
No regular file="/opt/splunk/etc/slave-apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.sh".
No regular file="/opt/splunk/etc/slave-apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.py".
No regular file="/opt/splunk/etc/slave-apps/TA-ta-hackerone/linux_x86_64/bin/hackerone.js".
No regular file="/opt/splunk/etc/slave-apps/TA-ta-hackerone/linux_x86_64/bin/hackerone".
No script found in dir="/opt/splunk/etc/slave-apps/TA-ta-hackerone/linux_x86_64/bin"
No regular file="/opt/splunk/etc/apps/TA-ta-hackerone/bin/hackerone.sh".
Found script "/opt/splunk/etc/apps/TA-ta-hackerone/bin/hackerone.py" to handle scheme "hackerone".
XML scheme path "/scheme/title": "title" -> "hackerone"
XML scheme path "/scheme/description": "description" -> "Go to the add-on's configuration UI and configure modular inputs under the Inputs menu."
XML scheme path "/scheme/use_external_validation": "use_external_validation" -> "true"
XML scheme path "/scheme/streaming_mode": "streaming_mode" -> "xml"
XML scheme path "/scheme/use_single_instance": "use_single_instance" -> "false"
XML arg path  "/scheme/endpoint/args/arg": "name" -> "name"
XML arg path  "/scheme/endpoint/args/arg/title": "title" -> "hackerone Data Input Name"
XML arg path  "/scheme/endpoint/args/arg": "name" -> "rest_version"
XML arg path  "/scheme/endpoint/args/arg/title": "title" -> "rest_version"
XML arg path  "/scheme/endpoint/args/arg/required_on_create": "required_on_create" -> "0"
XML arg path  "/scheme/endpoint/args/arg/required_on_edit": "required_on_edit" -> "0"
XML arg path  "/scheme/endpoint/args/arg": "name" -> "program_id"
XML arg path  "/scheme/endpoint/args/arg/title": "title" -> "program_id"
XML arg path  "/scheme/endpoint/args/arg/required_on_create": "required_on_create" -> "0"
XML arg path  "/scheme/endpoint/args/arg/required_on_edit": "required_on_edit" -> "0"
XML arg path  "/scheme/endpoint/args/arg": "name" -> "hackerone_api_credentials"
XML arg path  "/scheme/endpoint/args/arg/title": "title" -> "hackerone_api_credentials"
XML arg path  "/scheme/endpoint/args/arg/required_on_create": "required_on_create" -> "0"
XML arg path  "/scheme/endpoint/args/arg/required_on_edit": "required_on_edit" -> "0"
XML arg path  "/scheme/endpoint/args/arg": "name" -> "rest_endpoint"
XML arg path  "/scheme/endpoint/args/arg/title": "title" -> "rest_endpoint"
XML arg path  "/scheme/endpoint/args/arg/required_on_create": "required_on_create" -> "0"
XML arg path  "/scheme/endpoint/args/arg/required_on_edit": "required_on_edit" -> "0"
Setting up values from introspection for scheme "hackerone".
Setting "title" to "hackerone".
Setting "description" to "Go to the add-on's configuration UI and configure modular inputs under the Inputs menu.".
Setting "use_single_instance" to false.
Setting "use_external_validation" to true.
Setting "title" to "hackerone_api_credentials".
Setting "required_on_create" to false.
Setting "required_on_edit" to false.
Setting "title" to "hackerone Data Input Name".
Setting "title" to "program_id".
Setting "required_on_create" to false.
Setting "required_on_edit" to false.
Setting "title" to "rest_endpoint".
Setting "required_on_create" to false.
Setting "required_on_edit" to false.
Setting "title" to "rest_version".
Setting "required_on_create" to false.
Setting "required_on_edit" to false.
Introspection setup completed for scheme "hackerone".

 

Labels (2)
0 Karma
1 Solution

kmfpo
Explorer

I "solved" the issue by recreating my TA on a dev Splunk 8.0.4 and using the Add-On builder 3.0.1.  Once I did this, I was able to go to my built TA and add my API credentials under the configuration tab.

View solution in original post

Tags (1)
0 Karma

danieldd
Engager

I had this issue as well 

to fix it i did the below 

  1. Make a new directory called “local” in $SPLUNK_HOME/etc/apps/Splunk_TA_microsoft_cloudservices.
  2. Copy the $SPLUNK_HOME/etc/apps/Splunk_TA_microsoft_cloudservices/default/inputs.conf and $SPLUNK_HOME/etc/apps/Splunk_TA_microsoft_cloudservices/default/restmap.conf files to the new $SPLUNK_HOME/etc/apps/Splunk_TA_microsoft_cloudservices/local directory.
  3. Edit the inputs.conf and restmap.conf files in the $SPLUNK_HOME/etc/apps/Splunk_TA_microsoft_cloudservices/local directory and change “python3” to “python2”.
  4. Restart Splunk.

im still having an issue not showing the configs i have setup but at least it stops the never ending loading 

Tags (1)
0 Karma

kmfpo
Explorer

Unfortunately, the custom TA I am building does not have a /default/inputs.conf nor /default/restmap.conf

I already had a /local/restmap.conf and changed every instance of python to python2.  This caused the "Inputs" tab in the GUI of the TA to stay stuck on "loading" in addition to the "Configuration" tab.  I reverted back to python (from python2) and now the Inputs page loads, but the Configuration remains stuck on loading.

0 Karma

kmfpo
Explorer

I "solved" the issue by recreating my TA on a dev Splunk 8.0.4 and using the Add-On builder 3.0.1.  Once I did this, I was able to go to my built TA and add my API credentials under the configuration tab.

View solution in original post

Tags (1)
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!