All Posts

Find Answers
Ask questions. Get answers. Find technical product solutions from passionate members of the Splunk community.

All Posts

Give this a try   index="webmethods_prd" source="/apps/WebMethods/IntegrationServer/instances/default/logs/SupplierRTI.log" "SupplierRTI_AlphaAesar" | timechart span=1w count(eval('STAT... See more...
Give this a try   index="webmethods_prd" source="/apps/WebMethods/IntegrationServer/instances/default/logs/SupplierRTI.log" "SupplierRTI_AlphaAesar" | timechart span=1w count(eval('STATUS'=="fail")) as Failure, count as Total | eval Failurerate=('Failure'/'Total')*100, SuccessRate=100-'Failurerate' | fields + _time, Total, SuccessRate   Just by looking at your original queries I think the above SPL will do what you are asking for. Though, your text of query1 shows the index as XXXXXX but the screenshot show the same index/source as query2 so I was a little confused by that part. Let me know if you actually need to data from 2 different index/source together in a final report and I can give it another shot. Example of output from simulated data:  
how should I merge this 2 query into 1: query 1) index="XXXX" source="XXXX"|search "SupplierRTI_AlphaAesar" |stats count AS "Total",count(eval(STATUS=="fail")) AS Failure|eval Faliurerate=(Failur... See more...
how should I merge this 2 query into 1: query 1) index="XXXX" source="XXXX"|search "SupplierRTI_AlphaAesar" |stats count AS "Total",count(eval(STATUS=="fail")) AS Failure|eval Faliurerate=(Failure/Total)*100|eval SuccessRate=100-Faliurerate|table Total,SuccessRate query 2) index="webmethods_prd" source="/apps/WebMethods/IntegrationServer/instances/default/logs/SupplierRTI.log"|search "SupplierRTI_AlphaAesar" | timechart span=1w count I want a report like this how should I form the query?    
I would insist on treating it as a bug. https://docs.splunk.com/Documentation/Splunk/latest/SearchReference/CommonEvalFunctions says explicitly   len(<str>) Returns the count of the number of... See more...
I would insist on treating it as a bug. https://docs.splunk.com/Documentation/Splunk/latest/SearchReference/CommonEvalFunctions says explicitly   len(<str>) Returns the count of the number of characters, not bytes, in the string.
OK, I get your point but it works perfectly with FreeBSD 13.x and more importantly FreeBSD 11 itself has been «EOLed»  2 years and 3 months ago. So either Splunk has officially pushed new software ... See more...
OK, I get your point but it works perfectly with FreeBSD 13.x and more importantly FreeBSD 11 itself has been «EOLed»  2 years and 3 months ago. So either Splunk has officially pushed new software for years for an unsupported OS, or they just didn’t bother to update the doc. When they deprecated support for licensed products (ie full Splunk Enterprise) on FreeBSD, they documented that with proper warning. I see nothing about deprecating the Universal Forwarder package on FreeBSD…
I am subscribed to a 3rd party threat intelligence called Group-IB.  I have the Group-IBapp for splunk installed on my search head.  My question is in regards to tuning as I have done very little to... See more...
I am subscribed to a 3rd party threat intelligence called Group-IB.  I have the Group-IBapp for splunk installed on my search head.  My question is in regards to tuning as I have done very little to none. Should I expect that the threat intelligence that is streaming in is being ran against the events in my environment automatically? Assuming the threat intelligence is CIM compliant, should I expect that my Enterprise Security will make a notable event if there is a match?
Hi @eilonh, you can download the Enterprise Security App only if you are the referral people of a License (in this case, you should have received a link to download the Premium App) or the referral ... See more...
Hi @eilonh, you can download the Enterprise Security App only if you are the referral people of a License (in this case, you should have received a link to download the Premium App) or the referral people for a NFR License, that Splunk gives only to recognized Partners. If you want to see this app, you can access the Splunk Show (https://show.splunk.com/login/?redirect=/) and have a demo environment. Ciao. Giuseppe
Hi, When trying to download the enterprise security app, I'm getting the following comment: "This app restricts downloads to a defined list of users. Your user profile was not found in the list of ... See more...
Hi, When trying to download the enterprise security app, I'm getting the following comment: "This app restricts downloads to a defined list of users. Your user profile was not found in the list of authorized users..." What can I do to download it?
Appreciate to clarify if it still the same behavior or there's any changes can be done to show the data every 30seconds instead of 1 minute 
@0p3r4t0r8089 As a refresher, if you want to give credit as the correct answer, select the most helpful comment as solution, not the comment expressing credit:-)  Karma is also appreciated.
ERROR [2024-01-06 15:37:24,915] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Conne... See more...
ERROR [2024-01-06 15:37:24,915] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:285) ! at okhttp3.internal.connection.RealConnection.connect(RealConnection.kt:195) ! at okhttp3.internal.connection.ExchangeFinder.findConnection(ExchangeFinder.kt:249) ! at okhttp3.internal.connection.ExchangeFinder.findHealthyConnection(ExchangeFinder.kt:108) ! at okhttp3.internal.connection.ExchangeFinder.find(ExchangeFinder.kt:76) ! at okhttp3.internal.connection.RealCall.initExchange$okhttp(RealCall.kt:245) ! at okhttp3.internal.connection.ConnectInterceptor.intercept(ConnectInterceptor.kt:32) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.cache.CacheInterceptor.intercept(CacheInterceptor.kt:82) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.BridgeInterceptor.intercept(BridgeInterceptor.kt:83) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.RetryAndFollowUpInterceptor.intercept(RetryAndFollowUpInterceptor.kt:76) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.connection.RealCall.getResponseWithInterceptorChain$okhttp(RealCall.kt:197) ! at okhttp3.internal.connection.RealCall.execute(RealCall.kt:148) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:99) ! ... 13 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/192.168.27.207:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:280e:a326:367e:6dfb%5:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:1451:2eab:3b33:ff4d%11:9080 ! ... 30 common frames omitted ! Causing: java.lang.RuntimeException: Health check request failed to connect with exception ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:102) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequest(HealthCheckWrapper.java:71) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getClusterHealth(ESClusterHealthCheckStage.java:164) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getDetailedClusterHealth(ESClusterHealthCheckStage.java:102) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.execute(ESClusterHealthCheckStage.java:76) ! at com.appdynamics.platformadmin.core.job.JobProcessor.run(JobProcessor.java:260) ! at com.appdynamics.platformadmin.core.job.JobProcessor.call(JobProcessor.java:114) ! at com.appdynamics.platformadmin.core.service.JobExecutionServiceImpl.lambda$registerRecurringJobHelper$0(JobExecutionServiceImpl.java:204) ! at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1604) ! at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1596) ! at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ! at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ! at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ! at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:175) ERROR [2024-01-06 15:37:38,924] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:285) ! at okhttp3.internal.connection.RealConnection.connect(RealConnection.kt:195) ! at okhttp3.internal.connection.ExchangeFinder.findConnection(ExchangeFinder.kt:249) ! at okhttp3.internal.connection.ExchangeFinder.findHealthyConnection(ExchangeFinder.kt:108) ! at okhttp3.internal.connection.ExchangeFinder.find(ExchangeFinder.kt:76) ! at okhttp3.internal.connection.RealCall.initExchange$okhttp(RealCall.kt:245) ! at okhttp3.internal.connection.ConnectInterceptor.intercept(ConnectInterceptor.kt:32) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.cache.CacheInterceptor.intercept(CacheInterceptor.kt:82) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.BridgeInterceptor.intercept(BridgeInterceptor.kt:83) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.RetryAndFollowUpInterceptor.intercept(RetryAndFollowUpInterceptor.kt:76) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.connection.RealCall.getResponseWithInterceptorChain$okhttp(RealCall.kt:197) ! at okhttp3.internal.connection.RealCall.execute(RealCall.kt:148) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:99) ! ... 13 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/192.168.27.207:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:280e:a326:367e:6dfb%5:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:1451:2eab:3b33:ff4d%11:9080 ! ... 30 common frames omitted ! Causing: java.lang.RuntimeException: Health check request failed to connect with exception ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:102) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequest(HealthCheckWrapper.java:71) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getClusterHealth(ESClusterHealthCheckStage.java:164) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getDetailedClusterHealth(ESClusterHealthCheckStage.java:102) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.execute(ESClusterHealthCheckStage.java:76) ! at com.appdynamics.platformadmin.core.job.JobProcessor.run(JobProcessor.java:260) ! at com.appdynamics.platformadmin.core.job.JobProcessor.call(JobProcessor.java:114) ! at com.appdynamics.platformadmin.core.service.JobExecutionServiceImpl.lambda$registerRecurringJobHelper$0(JobExecutionServiceImpl.java:204) ! at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1604) ! at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1596) ! at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ! at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ! at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ! at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:175) INFO [2024-01-06 15:37:45,028] com.appdynamics.orcha.core.OrchaRunnerImpl: Running playbook K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\check-single-controller-appserver-processes.orcha with variables file K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\controller.groovy INFO [2024-01-06 15:37:45,032] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Uploading the diagnosis script if necessary INFO [2024-01-06 15:37:45,063] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Uploading the diagnosis script if necessary] completed executing in [14] ms. INFO [2024-01-06 15:37:45,074] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Setting execute permissions for the script INFO [2024-01-06 15:37:45,091] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Setting execute permissions for the script] completed executing in [11] ms. INFO [2024-01-06 15:37:45,101] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Running diagnosis scripts INFO [2024-01-06 15:37:45,705] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Running diagnosis scripts] completed executing in [596] ms. INFO [2024-01-06 15:37:45,719] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Stringify appserver diagnosis result INFO [2024-01-06 15:37:45,736] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Stringify appserver diagnosis result] completed executing in [11] ms. INFO [2024-01-06 15:37:47,208] com.appdynamics.orcha.core.OrchaRunnerImpl: Running playbook K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\check-single-controller-mysql-process.orcha with variables file K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\controller.groovy INFO [2024-01-06 15:37:47,211] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Uploading the diagnosis script if necessary INFO [2024-01-06 15:37:47,242] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Uploading the diagnosis script if necessary] completed executing in [13] ms. INFO [2024-01-06 15:37:47,254] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Setting execute permissions for the script INFO [2024-01-06 15:37:47,271] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Setting execute permissions for the script] completed executing in [11] ms. INFO [2024-01-06 15:37:47,282] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Running diagnosis scripts INFO [2024-01-06 15:37:48,170] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Running diagnosis scripts] completed executing in [879] ms. INFO [2024-01-06 15:37:48,183] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Stringify MySQL diagnosis result INFO [2024-01-06 15:37:48,202] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Stringify MySQL diagnosis result] completed executing in [12] ms. INFO [2024-01-06 15:37:48,231] com.appdynamics.platformadmin.controller.job.stages.ControllerHealthCheckStage: Discovered Primary controller health status on host 'welcomeB': UNHEALTHY. INFO [2024-01-06 15:37:48,231] com.appdynamics.platformadmin.core.job.JobProcessor: Platform/Job [1/e85fa4e1-fd2e-4ebc-aa0d-e3d77ff13258]: Ignored stage [controller_health_check_stage]'s error: [Health check result: Controller status check failed for the url http://welcomeB:8090/controller/rest/serverstatus with message: Health check request failed with HTTP 404: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><title>GlassFish v4 - Error report</title><style type="text/css"><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P{font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - </h1><hr/><p><b>type</b> Status report</p><p><b>message</b></p><p><b>description</b>The requested resource is not available.</p><hr/><h3>GlassFish Server Open Source Edition 4.1.1 </h3></body></html>] INFO [2024-01-06 15:37:48,245] com.appdynamics.platformadmin.controller.listener.ControllerRecurringJobListener: Controller listener expected health status [Critical] and received real time status [Critical] in platform 1 ERROR [2024-01-06 15:37:52,934] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:285) ! at okhttp3.internal.connection.RealConnection.connect(RealConnection.kt:195) ! at okhttp3.internal.connection.ExchangeFinder.findConnection(ExchangeFinder.kt:249) ! at okhttp3.internal.connection.ExchangeFinder.findHealthyConnection(ExchangeFinder.kt:108) ! at okhttp3.internal.connection.ExchangeFinder.find(ExchangeFinder.kt:76) ! at okhttp3.internal.connection.RealCall.initExchange$okhttp(RealCall.kt:245) ! at okhttp3.internal.connection.ConnectInterceptor.intercept(ConnectInterceptor.kt:32) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.cache.CacheInterceptor.intercept(CacheInterceptor.kt:82) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.BridgeInterceptor.intercept(BridgeInterceptor.kt:83) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.http.RetryAndFollowUpInterceptor.intercept(RetryAndFollowUpInterceptor.kt:76) ! at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:100) ! at okhttp3.internal.connection.RealCall.getResponseWithInterceptorChain$okhttp(RealCall.kt:197) ! at okhttp3.internal.connection.RealCall.execute(RealCall.kt:148) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:99) ! ... 13 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/192.168.27.207:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:280e:a326:367e:6dfb%5:9080 ! ... 30 common frames omitted ! Suppressed: java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ! at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ! at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ! at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ! at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ! at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ! at java.net.Socket.connect(Socket.java:613) ! at okhttp3.internal.platform.Platform.connectSocket(Platform.kt:117) ! at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.kt:283) ! ... 29 common frames omitted ! Causing: java.net.ConnectException: Failed to connect to welcomeb/fe80:0:0:0:1451:2eab:3b33:ff4d%11:9080 ! ... 30 common frames omitted ! Causing: java.lang.RuntimeException: Health check request failed to connect with exception ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequestOkHttp3(HealthCheckWrapper.java:102) ! at com.appdynamics.platformadmin.util.HealthCheckWrapper.healthCheckRequest(HealthCheckWrapper.java:71) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getClusterHealth(ESClusterHealthCheckStage.java:164) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.getDetailedClusterHealth(ESClusterHealthCheckStage.java:102) ! at com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage.execute(ESClusterHealthCheckStage.java:76) ! at com.appdynamics.platformadmin.core.job.JobProcessor.run(JobProcessor.java:260) ! at com.appdynamics.platformadmin.core.job.JobProcessor.call(JobProcessor.java:114) ! at com.appdynamics.platformadmin.core.service.JobExecutionServiceImpl.lambda$registerRecurringJobHelper$0(JobExecutionServiceImpl.java:204) ! at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1604) ! at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1596) ! at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ! at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ! at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ! at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:175) INFO [2024-01-06 15:37:56,850] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Connection failure while checking node health status on the host: welcomeB ERROR [2024-01-06 15:37:56,850] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ERROR [2024-01-06 15:38:00,860] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Connection failure while checking for number of data nodes on the host: welcomeB ERROR [2024-01-06 15:38:02,936] com.appdynamics.platformadmin.core.job.JobProcessor: Platform/Job [1/a6631ee1-e56a-4689-8d9a-4da5127b1e01]: Stage [es_cluster_health_stage] failed due to [Unable to check health of Events Service hosts [welcomeB] through port 9080.] INFO [2024-01-06 15:38:15,225] com.appdynamics.platformadmin.resources.VersionResource: Found Enterprise Console version 23.9.0-10017, build INFO [2024-01-06 15:38:45,045] com.appdynamics.orcha.core.OrchaRunnerImpl: Running playbook K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\check-single-controller-appserver-processes.orcha with variables file K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\controller.groovy INFO [2024-01-06 15:38:45,049] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Uploading the diagnosis script if necessary INFO [2024-01-06 15:38:45,080] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Uploading the diagnosis script if necessary] completed executing in [13] ms. INFO [2024-01-06 15:38:45,093] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Setting execute permissions for the script INFO [2024-01-06 15:38:45,109] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Setting execute permissions for the script] completed executing in [10] ms. INFO [2024-01-06 15:38:45,120] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Running diagnosis scripts INFO [2024-01-06 15:38:45,719] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Running diagnosis scripts] completed executing in [592] ms. INFO [2024-01-06 15:38:45,733] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Stringify appserver diagnosis result INFO [2024-01-06 15:38:45,751] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Stringify appserver diagnosis result] completed executing in [11] ms. INFO [2024-01-06 15:38:47,335] com.appdynamics.orcha.core.OrchaRunnerImpl: Running playbook K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\check-single-controller-mysql-process.orcha with variables file K:\Platform\platform-admin\conf\..\archives\platform-configuration\..\controller\23.9.0-10017\playbooks\controller.groovy INFO [2024-01-06 15:38:47,338] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Uploading the diagnosis script if necessary INFO [2024-01-06 15:38:47,377] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Uploading the diagnosis script if necessary] completed executing in [20] ms. INFO [2024-01-06 15:38:47,389] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Setting execute permissions for the script INFO [2024-01-06 15:38:47,407] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Setting execute permissions for the script] completed executing in [11] ms. INFO [2024-01-06 15:38:47,418] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Running diagnosis scripts INFO [2024-01-06 15:38:48,303] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Running diagnosis scripts] completed executing in [878] ms. INFO [2024-01-06 15:38:48,317] com.appdynamics.orcha.core.executor.DefaultPlaybookExecutor: Executing : Stringify MySQL diagnosis result INFO [2024-01-06 15:38:48,335] com.appdynamics.orcha.core.executor.TaskExecutor: Task [Stringify MySQL diagnosis result] completed executing in [11] ms. INFO [2024-01-06 15:38:48,364] com.appdynamics.platformadmin.controller.job.stages.ControllerHealthCheckStage: Discovered Primary controller health status on host 'welcomeB': UNHEALTHY. INFO [2024-01-06 15:38:48,364] com.appdynamics.platformadmin.core.job.JobProcessor: Platform/Job [1/e85fa4e1-fd2e-4ebc-aa0d-e3d77ff13258]: Ignored stage [controller_health_check_stage]'s error: [Health check result: Controller status check failed for the url http://welcomeB:8090/controller/rest/serverstatus with message: Health check request failed with HTTP 404: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><title>GlassFish v4 - Error report</title><style type="text/css"><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P{font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - </h1><hr/><p><b>type</b> Status report</p><p><b>message</b></p><p><b>description</b>The requested resource is not available.</p><hr/><h3>GlassFish Server Open Source Edition 4.1.1 </h3></body></html>] INFO [2024-01-06 15:38:48,379] com.appdynamics.platformadmin.controller.listener.ControllerRecurringJobListener: Controller listener expected health status [Critical] and received real time status [Critical] in platform 1 INFO [2024-01-06 15:38:56,856] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Connection failure while checking node health status on the host: welcomeB ERROR [2024-01-06 15:38:56,856] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ERROR [2024-01-06 15:38:56,878] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ! at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
After modifying the Controller's certificate and creating a new one, then after I tried to start the Controller again, but it did not start, nor did the event service. ERROR [2024-01-06 14:15:56,85... See more...
After modifying the Controller's certificate and creating a new one, then after I tried to start the Controller again, but it did not start, nor did the event service. ERROR [2024-01-06 14:15:56,850] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ERROR [2024-01-06 14:16:00,870] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Connection failure while checking for number of data nodes on the host: welcomeB ERROR [2024-01-06 14:16:02,866] com.appdynamics.platformadmin.core.job.JobProcessor: Platform/Job [1/a6631ee1-e56a-4689-8d9a-4da5127b1e01]: Stage [es_cluster_health_stage] failed due to [Unable to check health of Events Service hosts [welcomeB] through port 9080.] INFO [2024-01-06 14:16:12,208] com.appdynamics.platformadmin.resources.VersionResource: Found Enterprise Console version 23.9.0-10017, 14:17:24,850] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at 14:17:38,858] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at 4da5127b1e01]: Stage [es_cluster_health_stage] failed due to [Unable to check health of Events Service hosts [welcomeB] through port 9080.] INFO [2024-01-06 14:18:12,207] com.appdynamics.platformadmin.resources.VersionResource: Found Enterprise Console version 23.9.0-10017, build INFO [2024-01-06 14:18:43,400] com.appdynamics.orcha.modules.modules.UriExec: Sending request to: http://localhost:8090/controller/rest/serverstatus INFO [2024-01-06 14:18:56,827] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Connection failure while checking node health status on the host: welcomeB ERROR [2024-01-06 14:18:56,827] com.appdynamics.orcha.extensions.es.health.StoreNodeHealth: Failed to connect to welcomeb/2001:0:2851:782c:1451:2eab:3b33:ff4d:9080 ERROR [2024-01-06 14:18:56,839] com.appdynamics.platformadmin.es.job.stages.ESClusterHealthCheckStage: Failed to reach URL [http://welcomeB:9080/v1/store/report] ! java.net.ConnectException: Connection refused: connect ! at ES
Do you have any sourcetype renaming taking place or anything that might be changing the value of the sourcetype field? I am wondering if the data is not indexed with sourcetype WinEventLog but as so... See more...
Do you have any sourcetype renaming taking place or anything that might be changing the value of the sourcetype field? I am wondering if the data is not indexed with sourcetype WinEventLog but as something else (hence picked up when not specifying the sourcetype) and then once the events are being searched the sourcetype is changed to WinEventLog? Might be worth a check to start with, but please let me know how you get on as happy to help further if I can!
Hi All, https://docs.splunk.com/Documentation/Community/latest/community/SplunkIdeas How Ideas are reviewed and prioritized Due to our large and active community of Splunkers, the number of enhance... See more...
Hi All, https://docs.splunk.com/Documentation/Community/latest/community/SplunkIdeas How Ideas are reviewed and prioritized Due to our large and active community of Splunkers, the number of enhancement requests we receive can be voluminous. Splunk Ideas allows us to see which ideas are being requested most across different types of customers and end-user personas. When we determine which ideas to triage we look at total vote count across a variety of cohorts, which include but are not limited to: Number of total votes (this is the number displayed in the "Vote" box for an idea) Number of unique customers requesting an idea ("customers" refers to organizations, not employees) Number of votes by customer size or industry. For example: large, small, financial services, government, and so forth. Number of votes by customer geography. For example: Americas, Europe, Asia, and so forth. Number of votes by end-user persona. For example: admin, SOC analyst, business analyst, and so forth. Number of votes from special audiences. For example: Splunk Trust, Design Partners, and so forth.   Could some long time Splunkers please upvote the idea, so that the Splunk will review it please. thanks.    Best Regards, Sekar
Hi @meshorer  Could you pls update us more info..  >>> the Console Output is shown with dark text over dark theme, so it makes it difficult to read the output. I hope this is not the issue with Da... See more...
Hi @meshorer  Could you pls update us more info..  >>> the Console Output is shown with dark text over dark theme, so it makes it difficult to read the output. I hope this is not the issue with Dark Theme.  when you are in dark theme, pls suggest us how the dark text should be displayed, please suggest, thanks. 
Hi @Splunk3, If you're using Splunk Add-on for ServiceNow, new copies of table records are indexed by Splunk whenever the inputs sees a newer timestamp value in e.g. sys_updated_on. You most likely ... See more...
Hi @Splunk3, If you're using Splunk Add-on for ServiceNow, new copies of table records are indexed by Splunk whenever the inputs sees a newer timestamp value in e.g. sys_updated_on. You most likely want to calculate durations from the latest instance of the record indexed by Splunk: index=servicenow sourcetype=snow:change_request short_description IN ("abc", "xyz", "123") | stats latest(short_description) as short_description latest(eval(strptime(dv_closed_at, "%F %T")-strptime(dv_opened_at, "%F %T"))) as duration_secs by sys_id | stats avg(eval(duration_secs/3600)) as avg_duration_hours by short_description I'm using stats aggregation eval shortcuts, but at a high level, the search finds the most recent short_description and calculates the most recent duration by sys_id, and then calculates the average duration by short_description. If your changes are opened for long periods of time before approval and implementation, you may prefer to use the work_start and work_end fields or their equivalents, depending on your use case. Most orgs customize the change workflow and schemas to fit their service model.
Hi @mr103, It shouldn't have worked in 8.2. If present, static/appLogo.png and static/appLogo_2x.png supersede the app.conf [ui] label setting. static/appIcon*.png should be displayed on the home p... See more...
Hi @mr103, It shouldn't have worked in 8.2. If present, static/appLogo.png and static/appLogo_2x.png supersede the app.conf [ui] label setting. static/appIcon*.png should be displayed on the home page, the Apps menu, etc.
Hi @ssbapat, A complete stack trace would reveal more, but in a nutshell, certificate verification failed in the underlying SSL/TLS class. Does "splunk.org.company.com" (or the actual hostname) matc... See more...
Hi @ssbapat, A complete stack trace would reveal more, but in a nutshell, certificate verification failed in the underlying SSL/TLS class. Does "splunk.org.company.com" (or the actual hostname) match either the common name (cn) or a subject alternative name (SAN or subjectAltName) on the server's certificate? Are all certificates in the server's certificate chain trusted by the client?
Anyone? @phanTom 
Hello, After upgrading from 8.2 to 9.1 I noticed a change in the nav bar affecting most of the custom apps. On the right end of the nav bar, where the app logo (file appIcon*.png from the <appnam... See more...
Hello, After upgrading from 8.2 to 9.1 I noticed a change in the nav bar affecting most of the custom apps. On the right end of the nav bar, where the app logo (file appIcon*.png from the <appname>/static folder) is displayed, the app label (which is configured in app.conf as "label" in the [ui] section) is simply not showing. Strangely enough, for some applications, like "Search & Reporting", the text label is still appearing. But for the majority of the 3rd party apps from the splunkbase, and also for my own custom apps, the label is not showing at all. (For the record: the logo icon is showing, but the text label is not) This is very annoying. After some investigation, it seems that it is NOT an issue of some CSS styling. Because according to the Web Inspector in a browser, the html "span" element that should hold the app label, is NOT populated with the value configured in app.conf/[ui]/label. The "span" element is just empty Why is that ? Regards, mr
Jumping in on an aging topic, but you may be able to simplify the SPL, albeit with an unknown impact to performance. (Always test!) | makeresults format=json data="[{\"foo\": {\"field1\": \"value1\"... See more...
Jumping in on an aging topic, but you may be able to simplify the SPL, albeit with an unknown impact to performance. (Always test!) | makeresults format=json data="[{\"foo\": {\"field1\": \"value1\", \"field2\": \"value2\"}}, {\"bar\": {\"field1\": \"value3\", \"field2\": \"value4\"}}, {\"baz\": {\"field2\": \"value5\", \"field3\": \"value6\"}}]" | spath ``` end test data ``` | table *.* | transpose | rex field=column "(?<prefix>[^.]+)\\.(?<suffix>.+)" | foreach row* [ eval value=coalesce('<<FIELD>>', value) ] | xyseries prefix suffix value