Splunk Search

splunk add-on for Amazon Web services can't proxy and can't no_proxy

New Member

Trying to collect my AWS data using on-prem splunk instance. I need to go via a proxy to access anything on the internet sts.amazon.com etc for example.

I've added proxy settings to the environment and splunk-launch.conf which seems to do the trick for most other apps and I can get my newrelic data and can see the access via the proxy.

For the AWS app if I leave the app specific proxy config blank I can't add any account because it appears to be ignore the global proxy settings and trying to go direct when I click add.

If I configure the App specific proxy with the same settings as the system (except for the no proxy list because there is no setting for that) I can't even get to the account add screen because it is trying to proxy the call to the localhost:8089 mgt port.

Anyone know how to configure it to make it work?



Labels (1)
Tags (3)
0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.