Splunk Search

Web datamodel contains negative values for bytes ingested from Umbrella proxylogs

nagamadhupriyan
Loves-to-Learn Lots

The Web datamodel contains negative values for bytes ingested from Umbrella proxylogs

below is the query that we are using for the search

| tstats `summariesonly` sum(Web.bytes_out) as size_out, sum(Web.bytes_in) as size_in, values(Web.http_method) as method
from datamodel=Web.Web by Web.user,Web.url, _time span=1d
| `drop_dm_object_name("Web")`

Labels (2)
Tags (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @nagamadhupriyan ,

you should see how Datampdel is populated, maybe it uses a wrong field or a wrong field extraction.

Ciao.

Giuseppe

0 Karma

nagamadhupriyan
Loves-to-Learn Lots

Hi 

 

byte field :case(isnum(bytes),bytes,isnum(bytes_in) AND isnum(bytes_out),
bytes_in+bytes_out,1=1,null())
  

 

 

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Painting a Clearer Picture: Creating Cross-Domain Visibility with AI Canvas

Watch Now Painting a Clearer Picture: Creating Cross-Domain Visibility with AI Canvas     Do you ever feel ...

Build and Launch AI Agents from Your Splunk Workflows

Replay Tech Talk Build and Launch AI Agents from Your Splunk Workflows     We’ve all been there: juggling ...

index This | What kind of room has no doors?

IndexEducation Cover Art Banner Cisco.png August 2026 Edition  Hayyy Splunk Education Enthusiasts and the ...