Splunk Search

OR contition simulation between two search query

karakutu
Path Finder

since one of the username need to be simulate with regex query . I am forced to use regex

how can I do it so that I simulate kind of OR condition between main and sub search query

index=main
suser IN("abc","def")
| search  regex suser =”DEF[0-9]"
AND EventID IN("323","322")
 
Thanks
 
 
 
Labels (1)
Tags (1)
1 Solution

inventsekar
SplunkTrust
SplunkTrust

index=main suser IN("abc","def") [search regex suser =”DEF[0-9]" AND EventID IN("323","322") | fields suser] | table suser field1 field2

i am little confused about this OR requirement and i am little confused on the regex inside subsearch as well. maybe if you give us some sample logs, the subsearch may not be needed altogether. h

 

(i received 100 karma points giver badge, have you?!?!)

View solution in original post

karakutu
Path Finder

thanks for your support. sample log I can not give.

 

the problem is I have a special username which need to be simulate with regex.

since I can not user regex into IN function.   so I just want to simulate it separately. 

maybe I use unnecessary function. maybe we can do it much easier. I am not sure.

 

 

inventsekar
SplunkTrust
SplunkTrust

no need to write us the full logs. you can hide/edit the hostnames/confidential info in the logs and update us the sample log. 

0 Karma

inventsekar
SplunkTrust
SplunkTrust

index=main suser IN("abc","def") [search regex suser =”DEF[0-9]" AND EventID IN("323","322") | fields suser] | table suser field1 field2

i am little confused about this OR requirement and i am little confused on the regex inside subsearch as well. maybe if you give us some sample logs, the subsearch may not be needed altogether. h

 

(i received 100 karma points giver badge, have you?!?!)

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Turn Cisco Telemetry Into Action with Cisco Data Fabric, powered by the Splunk ...

The surge in machine data is already hitting enterprise budgets, and the agentic era will only intensify it. ...

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...