Splunk Search

Inconsistent results when searching using dedup sortby -_time

dstark75
New Member

I'm monitoring log files and want to generate reports using the most recent event types

I'm seeing an inconsistent number of results when I run a search:

index="myindex" source="/var/log/mysource" | dedup name sortby -_time | eventstats sum(passed) AS totalpassed | eventstats sum(failures) AS totalfailures | table totalpassed,totalfailures | head 1

I think my problem is the dedup statement, but can't figure out how. I tried different time intervals, but since these checks are run every minutes, I should be seeing the same results each search using the last 15 minutes.

0 Karma

hortonew
Builder

If you think the dedup is off, try verifying that you have the same number of users over a period of 15m time blocks

 index="myindex" source="/var/log/mysource" | timechart dc(name) span=15m
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...