Splunk Search

Hunk search problem: Cannot initialize Cluster.

Ledion_Bitincka
Splunk Employee
Splunk Employee

I've configured Hunk to run searches against my cluster however I keep running into this issue when I try to execute a reporting search (stats, top, chart etc) - streaming searches seem to be working just fine

   INFO  ERP.hadoop -  Cluster - Failed to use org.apache.hadoop.mapred.LocalClientProtocolProvider due to error: Invalid "mapreduce.jobtracker.address" configuration value for LocalJobRunner : "xxxx.splunk.com:8021"
    ERROR ERP.hadoop -  UserGroupInformation - PriviledgedActionException as:lbitincka (auth:SIMPLE) cause:java.io.IOException: Cannot initialize Cluster. Please check your configuration for mapreduce.framework.name and the correspond server addresses.
    ERROR ERP.hadoop -  AsyncMRJob - Cannot initialize Cluster. Please check your configuration for mapreduce.framework.name and the correspond server addresses.
    ERROR ERP.hadoop -  java.io.IOException: Cannot initialize Cluster. Please check your configuration for mapreduce.framework.name and the correspond server addresses.
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Cluster.initialize(Cluster.java:121)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Cluster.<init>(Cluster.java:83)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Cluster.<init>(Cluster.java:76)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1239)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1235)
    ERROR ERP.hadoop -      at java.security.AccessController.doPrivileged(Native Method)
    ERROR ERP.hadoop -      at javax.security.auth.Subject.doAs(Subject.java:415)
    ERROR ERP.hadoop -      at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Job.connect(Job.java:1234)
    ERROR ERP.hadoop -      at org.apache.hadoop.mapreduce.Job.submit(Job.java:1263)
    ERROR ERP.hadoop -      at com.splunk.mr.AsyncMRJob.run(AsyncMRJob.java:131)
    ERROR ERP.hadoop -      at java.lang.Thread.run(Thread.java:724)
Tags (2)
0 Karma

Ledion_Bitincka
Splunk Employee
Splunk Employee

This issue is caused by the Hadoop client libraries being incompatible with the Hadoop version that the cluster is running. In my case above I was using CDH4.3.1 libraries to talk to CDH4.3.0. The problem went away when using the same client library version as the cluster. To check for compatibility I would recommend running the following commands:

$HADOOP_HOME/bin/hadoop fs -ls hdfs://namenode:ipc_port/

$HADOOP_HOME/bin/hadoop jobs -jt jobtracker:ipc_port -list all
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner   Join us for a demo-driven look at how ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...