Splunk Search

How to exclude events through lookup?

mmoermans
Path Finder

Hi there,

trying to exclude some events through the use of a lookup but it's not working for some reason:

index=main src_ip="192.168.0.0/16" (dest_ip!="127.0.0.1" OR dest_ip!="127.0.0.2") | dedup dest_ip | lookup dns.csv destdns_ip as dest_ip OUTPUTNEW query  | search NOT [| inputlookup dns_excludes.csv | fields query ] | table dest_ip,query

dns.csv
dest_ip, query
127.0.0.5, windows.com

dns_excludes.csv
query
windows.com

It shows the data normally but doesn't exclude the dns_excludes.csv. Does anyone know what I'm doing wrong here?

0 Karma
1 Solution

somesoni2
Revered Legend

What does your lookup table contains? (provide field names and their sample values)

Also, give this a try (query is a special keyword in Splunk, so avoiding that)

 index=main src_ip="192.168.0.0/16" (dest_ip!="127.0.0.1" OR dest_ip!="127.0.0.2") | dedup dest_ip | lookup dns.csv destdns_ip as dest_ip OUTPUTNEW query  as query1 | search NOT [| inputlookup dns_excludes.csv | fields query | rename query as query1 ] 
 rename query1 as query | table dest_ip,query

View solution in original post

0 Karma

somesoni2
Revered Legend

What does your lookup table contains? (provide field names and their sample values)

Also, give this a try (query is a special keyword in Splunk, so avoiding that)

 index=main src_ip="192.168.0.0/16" (dest_ip!="127.0.0.1" OR dest_ip!="127.0.0.2") | dedup dest_ip | lookup dns.csv destdns_ip as dest_ip OUTPUTNEW query  as query1 | search NOT [| inputlookup dns_excludes.csv | fields query | rename query as query1 ] 
 rename query1 as query | table dest_ip,query
0 Karma

mmoermans
Path Finder

This fixed it, thanks!

0 Karma

MuS
SplunkTrust
SplunkTrust

Hi @mmoermans, please accept this answer if it helped to solve your problem.

cheers, MuS

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Catalog Is Now Generally Available on Splunk Cloud Platform

A Unified View of Your Data  Security logs, application events, business data, and historical telemetry often ...

Developer Spotlight with Eduard Lekanne

From Network Engineer to Building Agentic AI for Splunk Eduard Lekanne has been architecting technology ...

From Data Landing to Insight

Search Across More of Your Data Ecosystem The data you need may live in Splunk, high-volume machine data, ...