Splunk Search

How do you get the count value by using tstats or stats command?

rakesh44
Communicator

Hi Team,

I am using the below command for getting the total value of Payable_Column & show the total count:

index=ghl_gj sourcetype="Gaget" Period="Aug-18" | where date="2018-12-16" | stats count by Payable_Column | addcoltotals

Example

Payable_Column Count
1 1
2 2
3 2

Required
Payable_Column Count
6 5

0 Karma

sdchakraborty
Contributor
index=ghl_gj sourcetype="Gaget" Period="Aug-18" | where date="2018-12-16" | stats count by Payable_Column | stats  sum(Payable_Column) as Payable_Column , sum(count) as count

is that what you want?

Sid

0 Karma

rakesh44
Communicator

@sdchakraborty Perfect but it is taking too much time to fetch data , i have 4000000 events. Can we expedite by using tstats command

0 Karma

ddrillic
Ultra Champion

You can use tstats if the fields in the command are index fields.

0 Karma

rakesh44
Communicator

but what be the command

| tstats index=ghl_gj sourcetype="Gaget" Period="Aug-18" | where date="2018-12-16" | stats count by Payable_Column | stats sum(Payable_Column) as Payable_Column , sum(count) as count

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...